Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have had a running 13.04 system for quite some time now. However, I hadn't tried to install the NVIDIA drivers on it. I also had a similar problem on a 12.10 system. In the past I resolved this problem by re-installing the whole system.

I attempted to install nvidia-current from the repository, and for the most part it looked like it was successful, except that after reboot Unity was mostly borked. I could see the wallpaper and my Wine application icons on the desktop. No side-bar menu and no top panel and no response to the super-key. I could still do Ctl-Alt-T to get a terminal.

I removed/purged nvidia* thinking that would solve the problem. It DID NOT.

I thought I might just install another copy on a different partition, using the same home partition, then compare what might be different. That showed the same behavior!! So I created another account and when I logged into that voila, Unity is back to its original ugly(out of the box) self, in that account only.

So this suggests that rather than something buried deep in /etc it is something in my /home/<user>.

I doubt anyone can simply diagnose what is going on for me specifically, but can someone teach me to fish? Tell me what to look for to help diagnose what is happening. I have lots of stuff hidden and otherwise in my home directory, and there are all sorts of files in /var/log. But which ones, and what to look for is more of what I need. On the other hand, if someone knows how to fix this specific problem, I can take the next one as a learning experience instead.

-- B

share|improve this question
    
Can you try this answer askubuntu.com/a/204430/8698 ? –  Dan Sep 12 '13 at 16:31
add comment

2 Answers

This worked for me:

  1. Press Ctrl+Alt+T to open a terminal window.
  2. At the terminal prompt, type ccsm. If the CompizConfig Settings Manager window appears, skip to step nn. If not, continue with step
  3. Type sudo apt-get install compizconfig-settings-manager.
  4. Type your password when prompted.
  5. At the next terminal prompt, type ccsm.
  6. In CompizConfig Settings Manager, select the check box for the OpenGL plugin if it isn't already selected.
  7. Click the Ubuntu Unity Plugin item.
  8. Select the Enable Ubuntu Unity Plugin check box, if it isn't already selected.
  9. Exit from the CompizConfig Settings Manager.
  10. Press Ctrl+Alt+Delete. When asked, confirm that you want to log out.

I did a cold reboot at this point. I'm not sure it's necessary, but I'm a bit paranoid.

After this, Unity came up as it's supposed to for me.

I have a 64-bit i3 core CPU and an nVidia GPU; I'm running 64-bit Ubuntu with the nvidia-current driver set, and I've just upgraded to 13.04 (at which point Unity disappeared).

Hope this helps!

share|improve this answer
add comment

Reset Compiz and other configurations:

rm -r ~/.*

(This will erase settings and browser book marks)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.