Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First, a bit of background. I managed to dual boot Ubuntu 13.04 with Windows 8(preinstalled). I disabled secure boot. I had to go in the bios settings and change the disk order to select Ubuntu as the first disk(it created Ubuntu as a boot device). Grub would open and I only saw Ubuntu. I opened Ubuntu and ran boot repair and then when I rebooted I could see Ubuntu and windows 8. Both OS' worked perfectly.

After messing up Ubuntu, I decided that a reinstall was in order. However I decided to install elementary OS over Ubuntu. Since I only had 1 partition for Ubuntu (not counting swap) I simply deleted the partition, recreated a ext4 partition, and left the boot loader in its default place (dev/sa I believe ). Rebooted, again only option was elementary OS, so I ran boot repair once again, and sure enough I got my windows 8 back. Tried both and they both worked. I then was having a bit of trouble with elementary OS, so I decided to reinstall Ubuntu again. I repeated the same steps as before, deleted the 1 partition which contained elementary OS, and installed Ubuntu on a newly created partition.

This is where my problem begins. Upon rebooting after finishing the install, I would only get a blank screen. So I decided to look at my bios settings again and I noticed that elementary was still in the boot devices, instead of Ubuntu. I thought maybe booting in the live usb and running boot repair again would fix it. Ran the recommended action, rebooted and still got the blank screen. Looked at the boot devices in bios and elementary is still there.

I've tried a couple of different settings in boot repair, however I always get the blank screen. For some reason I cannot seem to remove elementary from the boot device list. Before installing elementary, Ubuntu was a boot device that I could pick from.

Any ideas on how to remove elementary from there and re-add Ubuntu so I can load grub and pick from my two OS'?

share|improve this question
    
So you boot, see the normal logos, and then just a black screen? You can't get a grub menu? –  Richard Sep 11 '13 at 23:38
1  
askubuntu.com/questions/343432/… You may be able to use UEFI menu or command line efibootmgr. sudo efibootmgr -v The "-v" option displays all the entries so you can confirm you're deleting the right one, and then you use the combination of "-b ####" (to specify the entry) and "-B" (to delete it). Examples $5 is delete: linux.dell.com/cgi-bin/gitweb/… software.intel.com/en-us/articles/efi-shells-and-scripting –  oldfred Sep 12 '13 at 0:50
    
@searchfgold6789 I see the regular boot sequence, however once the grub menu would normally be there, I get a blank screen. –  Moosehead Sep 12 '13 at 0:57
    
@oldfred so I would boot into the live usb, then from the terminal run sudo efibootmgr -v command, right? I will attempt this in the morning. –  Moosehead Sep 12 '13 at 0:59
1  
@oldfred - My man! That worked beautifully. I managed to delete the elementary boot device from efibootmgr. I then re-ran the boot repair, crossed my fingers and rebooted and BAM grub menu is back and both OS' are listed and working perfectly. Next time beer is on me. –  Moosehead Sep 12 '13 at 11:09
show 1 more comment

1 Answer 1

See what @oldfred said..

You may be able to use UEFI menu or command line efibootmgr. sudo efibootmgr -v The "-v" option displays all the entries so you can confirm you're deleting the right one, and then you use the combination of "-b ####" (to specify the entry) and "-B" (to delete it). Examples $5 is delete: linux.dell.com/cgi-bin/gitweb/… software.intel.com/en-us/articles/efi-shells-and-scripting – oldfred

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.