Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having trouble while installing Ubuntu (12.04 LTS) (overwriting win7). Afterwards, I encountered (similar to this one ->

'Unable to install GRUB in dev/sdb'
 Executing 'grub-install/dev/sdb'
 This is a fatal error!

The installation finished and the PC was required to reboot. Afterwards, I never got past the bios screen (where the screen indicates that it is loading something; booting a CDROM, a USB, or so on). Actually, just stuck to the bios. I was unable to boot from any device (CDROM, HDD)

*I am using a gigabyte motherboard(GA-EP31-DS3L). Thanks!

I have also just tried using another hard drive just in case I have hardware issues.. but it's working smoothly. Although, I haven't tried installing Ubuntu on the hard drive I was referring to.

P.S: I used a CD to install Ubuntu.

share|improve this question
After getting the installation error, check /var/log/syslog for more details and edit it into your question. – psusi Sep 11 '13 at 22:27

This might be solved by running boot-repair:

It should either reinstall Grub correctly, or give you some helpful info you can add to this question so we can help you better.

share|improve this answer

My workaround (Ubuntu 14.04.1): unplug all hard drives except for the one that Ubuntu is being installed on. That stopped Ubuntu from installing on one disk and grub installing (well, failing to install) on another.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.