Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Apt resulted few erronous lines on dist-upgrade.

Preparing to replace gir1.2-mutter-2.91 2.91.93-0ubuntu1~build1 (using .../gir1.2-mutter-2.91_3.0.0-0ubuntu1~build1_amd64.deb) ...
Unpacking replacement gir1.2-mutter-2.91 ...
dpkg: error processing /var/cache/apt/archives/gir1.2-mutter-2.91_3.0.0-0ubuntu1~build1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/mutter/Meta-3.0.typelib', which is also in package gir1.2-mutter-3.0 3.0.0-0ubuntu1~build2
Errors were encountered while processing:
 /var/cache/apt/archives/gir1.2-mutter-2.91_3.0.0-0ubuntu1~build1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

NOTE. I have also installed gnome-shell, Other desktops (Unity, Classic) does not load and report error (Could not load ths session etc.) on login time. So Using gnome-shell.

share|improve this question
    
Welcome to Ask Ubuntu! 11.04 is currently in Beta so things might not work right. Please file a bug on this issue. –  Jorge Castro Apr 11 '11 at 13:30

2 Answers 2

up vote 2 down vote accepted

Looks like the same file exists in two distinct packages: gir1.2-mutter-3.0 and gir1.2-mutter-2.91 (note these are package names without version numbers). You could:

  1. Remove one of the packages, probably gir1.2-mutter-3.0. The downside is that this could force you to remove other packages that depend on it.

  2. Install gir1.2-mutter-2.91 using dpkg --force-overwrite, which will overwrite the conflicting file. There is a small risk that this could cause problems, but you can always recover by reinstalling the old version.

share|improve this answer

Please make sure that there's a bug filed about this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.