Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems I have a problem, and am only making it worse by following what I find online. I have a new Asus N550JV-D71 (not sure about the part after the dash, though I definitely know it includes 71). I decided to downgrade Windows 8 to 7, then dual boot Ubuntu 12.04 with it (there were issues with Windows 8, and I had a Windows 7 disk handy). It did work and, after installing Bumblebee in tty (because it wouldn't boot when it was first installed), it worked marvelously for a little less than a week. However, I restarted it last night and got the Could not write bytes: Broken pipes error. (I see it's a very common error, but I've looked at the majority of the suggested Similar Questions already.) I followed what I could find online, followed those instructions (making sure to not install any sort of graphics drivers other than what Bumblebee provides), and it just seems to go further and further downhill.

I'm afraid I didn't write the exact steps to get to this point (it was late by the time I gave up the night before), but it involved reinstalling lightdm, xorg (and xserver?), and Bumblebee. I then changed the Bumblebee.conf file so that Device=nvidia. I'm pretty new to Linux in general (I've used it since 10.04, but I hadn't had issues up until this computer, so it let me stay a newbie), so I'm not exactly sure what log files to look at to find the errors to look up. However, I did look at lshw and noticed that displays was marked as unassigned. Also, if I try to start lightdm using the command line, it always stops at Stopping Mount network filesystems. I should note that there isn't an xorg.conf file, and no .Xauthority.

I would really, really prefer not to reinstall 12.04 if possible. I managed to get grub to display only a short time ago, and I can't boot to the dvd drive unless I go into the BIOS settings and manually change the boot order (that was an issue from the beginning, before the Ubuntu install), and getting into those settings often means rebooting several times due to the fact that the window to get to it is extremely small. I have most of what I need backed up, however, in case it does get to that point. If I really have to, I can just use the latest Ubuntu version instead of the LTS, but the reason I chose 12.04 in the first place is because I need something stable-ish, and Windows isn't suitable to what I need to do.

I should note that the reason I restarted last night in the first place was that it wasn't charging the battery, and the wifi kept on going out.

Hardware:
Nvidia GeForce GT 750M
Intel HD graphics 4600

share|improve this question
    
In case you're still stuck at could not write bytes... you can reinstall the default graphic driver to fix this by uninstalling anything nvidia related and then doing sudo apt-get install xserver-xorg-lts-raring –  Tom Sep 13 '13 at 22:56

2 Answers 2

I cannot advise on this specific issue, but I'd like to share my experience in maintaining/troubleshooting ubuntu. Upon installation of OS I also install mercurial (hg), then go to /etc and do sudo hg init, sudo hg add, sudo hg commit -m 'initial configuration'. Periodically, or when doing tricky things, I do sudo hg add and sudo hg commit – to save the states of /etc.

When I'm in trouble, I use sudo hg diff to see what's changed. This unix philosophy of keeping all the configuration under one hood and this trick helped me a number of times.

P.S. It's fine for home. Not for corporate environment (where it might be of a security concern)

share|improve this answer

I answered this before but apparently it was to wordy and got "deleted" for not answering so here is my next try at this without the explainations for why.

I have the exact same Haswell and 750M nvidia so I know exactly what you mean. For me, I was able to get the system working again by uninstalling the nvidia-prime dependency.

sudo apt-get purge nvidia-prime

That got most of the things working again just restarting lightdm after uninstalling that. Not explaining why this time since that is apparently off topic. What did not still work after that was the "optimus" system but I expect it to get worked out soonish by others.

If you cannot wait and want the optimus system working ASAP, then uninstall everything "raring" related and install "quantas" related equivalents instead. Then install the bumblebee/primus systems like normal and you are good. Remember both the xserver and the kernel must be of the quantas variety not raring in order to get optimus working again right now. If you still have a raring kernel installed, it will default to that kernel on bootup so manually switch to the quantas kernel or remove the raring kernel completely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.