Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a lot of trouble getting Ubuntu 12.04 LTS running smoothly on my laptop. The computer has Nvidia Optimus, with an integrated HD4000 and a discrete Nvidia GTX 765M.

Initially I was just getting a black screen on startup; I installed Bumblebee and can now get to the desktop if I add the nomodeset argument (nomodeset didn't work by itself without bumblebee). Now:

1) Unity doesn't start, and trying to open it manually gives me errors;

2) Additional Drivers says that the Nvidia graphics driver is activated but not in use;

3) Trying to run glxgears or glxspheres gives me this error:

Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

4) Trying to run 'optirun glxgears` gives me this error:

[ 2028.461627] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[ 2028.461673] [ERROR]Aborting because fallback start is disabled.

I've spent all day reading through posts about problems with Optimus, but nothing so far has helped.

share|improve this question
@Eliah Damn, sorry; I'm running 12.04 LTS, not 10.04. Apologies for the mixup. Now could you reopen it? – Joe Sep 11 '13 at 22:51
12.04 is definitely still supported. You're right this shouldn't be closed as off-topic (thanks for editing to clarify). I didn't mention this in my previous comment because I was bumping up against the max comment length, but actually this question has not been closed. All that happened was that I had voted to close it; in light of the new information about how you're actually running 12.04 and not 10.04, I have retracted my close vote. This remains open and anyone may post answers. (This might ultimately end up as a duplicate of some other Optimus question, but it's certainly on-topic.) – Eliah Kagan Sep 11 '13 at 22:54
Oh, ok, thanks. There's a whole host of similar questions about Optimus here, but the solutions didn't help me, and I'm hoping that my specific error messages might help solve the issue. – Joe Sep 12 '13 at 0:04

Got the same error:

Error: couldn't get an RGB, Double-buffered visual

But optirun glxgear works now. I've done it like this: How to install nvidia optimus driver on ubuntu 12.10?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.