Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu 12.04.3 both 64-bits and 32-bits, but in both cases always occurred an error when the installation finish: “Executing ‘grub-install /dev/sda’ failed. This is a fatal error.”

However, when I installed for example PCLinuxOS or Ubuntu 13.04, there was no problem with GRUB even using the same partition scheme.

What kind of problem is there?

Edit:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000ea73f

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      718847      358400    7  HPFS/NTFS/exFAT
/dev/sda2          718848   164341759    81811456    7  HPFS/NTFS/exFAT
/dev/sda3       164341760   527066084   181362162+   7  HPFS/NTFS/exFAT
/dev/sda4       527067134   625141759    49037313    5  Extended
/dev/sda5       619278336   625141759     2931712   82  Linux swap / Solaris
/dev/sda6       568029184   619276287    25623552   83  Linux
/dev/sda7       527067136   568027135    20480000   83  Linux

Partition table entries are not in disk order

And here is the OS I have installed in each partition:

sda1 for "System Reserved" (Windows boot)
sda2 for Windows 8.1
sda3 for no OS
sda5 for swap
sda6 for /home
sda7 for /

I verified the md5 of the ISO. Also, I tried to install with different USB sticks and tried to install another Ubuntu-based distro (elementary OS that I think is based on 12.04.2) and the problem occurred too.

The strangest thing is that I installed Ubuntu 12.04 on this laptop in the past but I can't now.

share|improve this question
    
Could you be more descriptive? Have you verified the CD image? Is there another operative system installed? What is the partition scheme you are using? –  Braiam Sep 11 '13 at 18:21
    
@Braiam I've just updated the post with the answer to your questions. –  Kern Goldstein Sep 11 '13 at 18:59
    
Did you read this link askubuntu.com/questions/221835/… ? –  Braiam Sep 11 '13 at 19:04
    
@Braiam But my laptop doesn't have UEFI. It had a Windows 7 pre-installed, so I don't think that it is the solution. Moreover, I can install other distros. –  Kern Goldstein Sep 11 '13 at 19:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.