Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had set the boot preference to USB drive on my desktop which was running on Ubuntu 13.04. Yesterday I plugged in a USB and on switching on the comp it started to boot from the USB drive. When I saw that I immediately pulled the USB out (my bad!) and the comp was stuck. But when I re started it, it booted normally but gets stuck on the login screen. The OS does not recognize either the keyboard nor the mouse. I tried using Boot Repair but that did not help. The link that Boot Repair provided me is http://paste.ubuntu.com/6092970/ My system is also running Win8 and it doesn't have any problem. Its urgent that I fix it soon so any help would be much appreciated!

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted
+100

It must be an issue with a broken Kernel image. Just log into command-line/Terminal and run sudo apt-get install --reinstall linux-image-generic linux-image

See if the issue is fixed after a reboot.

share|improve this answer
add comment

Well I figured out the problem. During the broken boot my kernel Linux 3.8.0-29 generic had become corrupt. When I tried booting from an older version of the Linux kernel, it booted up normally. So now I just have to re install the broken kernel!

share|improve this answer
    
sudo apt-get install --reinstall linux-image-generic linux-image –  Joren Sep 17 '13 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.