Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

in the maas portal :ht tp://192.168.101.148/MAAS,i can see 6 nodes,and the status are all:ready.

and my environments.yaml file is :

environments:

  maas:
    type: maas
    maas-server: ht    tp://192.168.101.148:80/MAAS
    maas-oauth: "the key i get from the portal"
    admin-secret: super-secret-made-up-admin-key
    default-series: precise 

and the error is below:

root@ubuntu:~# juju bootstrap
2013-09-11 15:55:31,557 INFO Bootstrapping environment 'maas' (origin: distro type: maas)...
2013-09-11 15:55:32,222 ERROR Failed to launch machine /MAAS/api/1.0/nodes/node-e097fab8-1a11-11e3-a94b-0800270f346d/; attempting to release.
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/juju/providers/maas/launch.py", line 48, in start_machine
    instance_uri, cloud_init.render())
ProviderInteractionError: Unexpected Error interacting with provider: 403 FORBIDDEN
Unexpected Error interacting with provider: 403 FORBIDDEN
2013-09-11 15:55:32,404 ERROR Unexpected Error interacting with provider: 403 FORBIDDEN
share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I had the same problem, had better luck by using juju from the PPA instead of the default precise apt repository.

Install add-apt-repository tool:

sudo apt-get install python-software-properties

Add Juju PPA:

sudo add-apt-repository ppa:juju/stable

Install Juju core:

sudo apt-get update
sudo apt-get install juju-core
share|improve this answer
add comment

There is a fix in precise-proposed, enable this in your /etc/apt/sources.list:

And then:

sudo apt-get update
sudo apt-get upgrade

and then restart MAAS with

sudo /etc/init.d/maas restart

this will solve your issue.

share|improve this answer
1  
Could you provide references to this fix? Also, I know how to enable precise-proposed, but the asker may not. Could you be more verbose? –  Braiam Sep 11 '13 at 12:57
    
侯老师,我在网上看到过您的课程。我上面的这套环境已经破换了,我需要重新安装一套。你有邮箱吗,我把我的安装步骤给您发一下,您帮忙看看我的操作是否有问题,可以吗? –  tgc Sep 12 '13 at 7:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.