Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 12.04 on the Windows partition of my Macbook Pro Model 8.1. Everything seemed to go smoothly during installation however as I am trying to connect to wireless internet, I have had no luck.

I have gone to the update manager and installed all of the updates that were ready on my first usage of Ubuntu. I have rebooted and there is still no sign of connectivity. I went to add additional drivers and there is one listed - 'Broadcom STA wireless driver.' When I go to activate this driver, I receive an error message that reads 'Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log.'

After this I have tried removing Ubuntu and reinstalling it on my Windows partition. This led me to the same place.

The internet will connect when I use ethernet.

After using lspci -nn -d 14e4: I receive the following specifications.

 02:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM57765 
 Gigabit Ethernet PCIe [14e4:16b4] (rev 10)

 02:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 
 SDXC/MMC Card Reader [14e4:16bc] (rev 10)

 03:00.0 Network controller [0280]: Broadcom Corporation BCM4331 
 802.11a/b/g/n [14e4:4331] (rev 02)

I have tried rebuilding the bcmwl-kernel-source using the command sudo apt-get purge bcmwl-kernel-source and then sudo apt-get install bcmwl-kernel-source. Yet, nothing. I receive a warning that says Warning: No support for locale: en_US.utf8. I am not sure if this information is pertinent to the overall task.

Thank you to anyone who might have suggestions. I am very new to Ubuntu and still trying to get used to the in's and out's of it. Thank you!

share|improve this question
    
The answer depends a great deal on your exact device. bcmwl-kernel-source is not correct for every Broadcom device and most certainly not for every device for which Additional Drivers offers to install it. Please edit your question to add details of your wireless device from the terminal command: lspci -nn -d 14e4: –  chili555 Sep 11 '13 at 12:01

1 Answer 1

It seems that Broadcom wireless strike again.

You said recently. What kernel does your installation use? Is it 3.8? If yes, install a 3.2 or 3.5 kernel series. There is a known issue with Broadcom STA wireless driver and the 3.8 kernel.

For 3.2:

sudo apt-get install linux-image-generic
sudo apt-get install linux-headers-generic

For 3.5:

sudo apt-get install linux-image-generic-lts-quantal
sudo apt-get install linux-headers-generic-lts-quantal

And then try the driver installation again, the chances are that it will succeed. You will need an active internet connection to perform these tasks (eg. wired).

Regards.

share|improve this answer
    
Thank you for the suggestions. I have tried installing both the 3.2 and the 3.5 kernel series but there are no changes. Do I have to remove the 3.8 first? Also, I have added some information to my original post. –  Luke Benedict Sep 11 '13 at 15:37
    
I removed the 3.8 kernel series using the command: sudo apt-get purge linux-image-3.8.2 and rebooted and the wifi is up and running! Thank you so much! –  Luke Benedict Sep 11 '13 at 16:23
    
You were probably booting the 3.8 kernel again, this is why it was not working in the first place (you can choose to boot older kernels in the "Previous Linux versions" GRUB option). You are welcome! –  errikos Sep 11 '13 at 16:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.