Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't run xRDP out of the box in ubuntu 10.04. I run xrdp on a laptop and try to connect to it using Window RDP client. It connect to RDP which prompt for a type of connection I tried any of them but all can;t work it gives a connection error. I got the following in the log.

[20110410-18:57:51] [INFO ] scp thread on sck 5 started successfully
[20110410-18:57:51] [INFO ] granted TS access to user test
[20110410-18:57:51] [INFO ] starting Xrdp session...
[20110410-18:57:51] [INFO ] starting sessvc - xpid=7046 - wmpid=7045
[20110410-18:57:52] [INFO ] session 7044 - user test - terminated

Any Ideas?

share|improve this question

migrated from stackoverflow.com Apr 10 '11 at 18:25

This question came from our site for professional and enthusiast programmers.

2 Answers 2

I had problems the xRDP package for 10.4. I downloaded an installed the package from 10.10 and it works well. I also had problems with some of the VNC servers. I am currently running vnc4server successfully.

See my setup for Remote Desktops with VNC and RDP for more details.

share|improve this answer

I have installed vnc4server (xvnc) and I use "sesman-Xvnc" as module. I am running ubuntu 10.10 however.

Note that xrdp has to connect to a VNC server, so you have to have a vnc server installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.