Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to get my WiFi drivers on my laptop working for a week or so now and every video and thread has not helped me out. I know I need to use sudo apt-get install b43-fwcutter but whenever I type it into terminal, I get:from terminal....

Reading package lists... done 
Building dependency tree
Reading state information... Done 
E: Unable to locate package b43-fwcutter
A suggestion was to put lspci -vvnn | grep 14e4 in terminal:

09:Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5755M Giga bit     Ethernet Pci Express [14e4:1673] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation Bcm4311 802.11b/g WLAN     [14e4:4311](rev01) 
sudo apt-get install linux-firmware-nonfree:

Reading package lists... done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-firmware-nonfree .
share|improve this question

2 Answers 2

When you type sudo apt-get install packageName, apt looks for package 'packageName' in the repositories listed in the configuration file /etc/apt/sources.list.

Error E: Unable to locate package xxx indicates that the package cannot be found among the package lists retrieved from all the repositories listed in sources.list. Causes for this can be:

  1. The package does not exist at all (for example a typo in the name).

  2. The package exists in a repository that is not listed in your sources.list

  3. The package exists in a repository that is listed in sources.list, but you have not retrieved the lists of packages contained in that repository to your machine yet.

In your case:
(1) is excluded as I can find both packages 'b43-fwcutter' and 'linux-firmware-nonfree' from my own machine.
(3) is easy to check: just run sudo apt-get update before the apt-get install command and see if it works now.
(2) is however the cause I would bet on. Maybe you removed the repositories in the 'Software and Updates' UI? If so, please try to reselect everything in the 'Ubuntu Software' tab there and retry here above update+install procedure. Alternatively, refer to the accepted answer to the AskUbuntu topic 'How do I restore the default repositories?' to restore the default apt configuration.

share|improve this answer
    
Okay that worked but know when i type in {sudo apt-get update} i get.... E: Unable to lock administration directory (/var/lib/dpkg/), is another process using it? –  Max doll Sep 11 '13 at 0:21

Download this file b43 to a flash drive then drag and drop the file to your ubuntu desktop. Right-click it and select Extract Here. Open a terminal and do:

sudo mkdir /lib/firmware/b43

sudo cp Desktop/b43/* /lib/firmware/b43

sudo rmmod -f b43

sudo rmmod -f ssb

sudo modprobe b43

if you have not installed any other wireless driver your wireless should now be working.

These directions are for installing the driver without internet connection if you have working internet then just download the file to your desktop and follow the directions above.

share|improve this answer
    
Theres no link it just says b43.zip? –  Max doll Sep 11 '13 at 23:57
    
I fixed the link. –  Wild Man Sep 12 '13 at 0:05
    
How do i know what file to download? –  Max doll Sep 12 '13 at 0:40
    
Click on the b43.zip it will take you to the forum post 8 has a file that says b43.zip download it. You may have to create an account to be able to download the file I am not sure because the forum has redone their security. –  Wild Man Sep 12 '13 at 0:44
    
This worked for me, the first time I ran "sudo modprobe b43", my laptop crashed, but after running apt update and a reboot it worked. –  FarhadA May 1 at 19:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.