Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Question

How can ubuntu be configured so that you don't got the "waiting for network configuration..." message at boot if you got more than one adapter?

Facts

  • I've got an untouched Ubuntu here in Virtual Box and In VM-Ware Workstation.

  • My /etc/network/interfaces file is untouched and I've activated a Nat adapter to use the host systems real network card.

  • Additionally I've activated a host only adapter to be able to use a separate IP for connections between the VM and the host system.

Deduction

I figured out that the interfaces file needs only one gateway entry and this is given trough

auto eth0

iface eth0 inet dhcp.

So this is the entry for the first network adapter that provides gateway information and so the second configuration has no need for a line called

gateway 192.168.1.1.

For me that means the second entry has to look like this:

address 192.168.217.131

depending on what the router tells you as network address for the interface configured trough dcp and the second line here is the netmask. In common cases this is

netmask 255.255.255.

So the entire `/etc/network/interfaces'-file looks like this:

#This file describe the network interfaces available on your system
#and how to activate them. For more information see interfaces(5).

#The loopack network interface 

auto lo
iface lo inet loopback

#The primary network interface 

auto eth0 
iface inet dhcp

auto eth1
iface eth1 inet static

address 192.168.217.131
netmask 255.255.255

#No need for gateway here because this is already provided by the dhcp entry.

In this example I've taken the IP address provided by Ubuntu's ^server (Basic Ubuntu Server) package what was 192.168.217.130 and increased it by one.

Now I restart Ubuntu and got the message Waiting for network Configuration... where Ubuntu try to wait for network connection about 2 minutes.

I've had the same on Virtual Box.

share|improve this question

3 Answers 3

up vote 5 down vote accepted

There are two things to know

  1. As already mentioned above there is no need for a second gateway with a dhcp server in your network because the gateway entry is generated from there.

  2. After you've added a host-onely adapter you have to copy the ip-adress from your windows host.

So far.

Here is an example configuration for a host only connection with one additional adapter:

auto eth1

iface eth1 inet static
address 192.168.253.128
netmask 255.255.255.0
network 192.168.253.1
broadcast 192.168.253.255

The Third block of the network line depends on your ip. the broadcast line is needed for network communication between the host and the guest. This is a networking protocol related thing.

share|improve this answer
    
NO, you do not have to copy the IP address of the host. You can simply set any IP address to your VM with a host only network option. –  begueradj Jul 17 at 8:28

If you want to connect your VM to your home network with deferent ip than host system then you should choose Bridge option. In this advance options you need to choose allow to all for communications between VM to host, Vm to Vm.

You need to choose Bridge connection for second Network Adapter. You also need to configure dns-nameservers and gateway as this Network Adapter is different from first.

Here in your configuration file netmask should be

netmask 255.255.255.0
share|improve this answer

Something extra would be neccessary for networking to be up and running on some occasions. Providing dns-nameservers in /etc/network/interfaces file instead of '/etc/resolvconf/resolv.conf.d/base' file. Example:

auto eth1

iface eth1 inet static
address 192.168.217.131
netmask 255.255.255.0
network 192.168.217.1
broadcast 192.168.217.255
gateway 'provide your gateway here might be necessary'
dns-nameservers 'provide your nameserver here'

Finally,

sudo restart network-manager
share|improve this answer
1  
Thanks for mentioning the dns-nameservers option, couldn't get updates without it. –  mikewhatever Jul 2 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.