Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 10.10, ghc 6.12.1, gcc 4.4.5.

I am trying to install Nikki And The Robots.

When I do cabal install it fails to install Cabal- Cabal- already exists in ~/.cabal/lib. If I run cabal install --dry-run -v, it will say:

In order, the following would be installed:
Cabal- (reinstall) changes: unix- ->
cabal-macosx-0.1.1 (new package)
nikki-0.2.20 (new package)

Cabal fail to install with:

/home/tyr/.cabal/lib/unix- In function `spzw_info':
(.text+0x4d14): undefined reference to `rtsTimerSignal'
collect2: ld returned 1 exit status
cabal: Error: some packages failed to install:
Cabal- failed during the configure step. The exception was:
ExitFailure 1

How do I fix this?

I have tried renaming the .cabal folder to force it to reinstall, but it still fails.

share|improve this question

migrated from Apr 10 '11 at 16:37

This question came from our site for professional and enthusiast programmers.

Migrated to Ask Ubuntu? Really? There are more correctly answered problems of this type on Stackoverflow, it even has the 'cabal-install' tag. The fact that this happened on a linux box is rather incidental? – Theo Belaire Apr 10 '11 at 16:57
Linker error, caused by a buggy compiler with a strong community on StackOverflow? Ask Ubuntu!!! – TomMD Apr 10 '11 at 17:17
up vote 2 down vote accepted

You seem to have a broken compiler setup. The symbol you referred to should be in libHSrts_thr.a (or a variant, such as the non-threaded). I suggest you download and use a new copy of GHC, might as well be 7.0.3 while you're at it.

If you really want to investigate more then grep for rtsTimerSignal in the objdump -t libHSrts*.a output. Also, you could try to use the threaded rts (ghc -threaded) or non-threaded depending on which one is failing here.

share|improve this answer
I already have a version istalled form source sitting in a folder, as I was poking around in it, so I'm just going to run make install on it and try again. Thanks. – Theo Belaire Apr 10 '11 at 17:30
Well, now Network/Socket.hsc is failing with an Ambiguous Reference to closeFDWidth. sigh and thhis is why you list the functions you are importing. – Theo Belaire Apr 10 '11 at 17:46
What! They do, and it's protected by two mutually exclusive ##if on MIN_VERSION_base(4,3,1) s. This is odd – Theo Belaire Apr 10 '11 at 17:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.