Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using ubuntu (well, kubuntu to be precise) and my KDE desktop feels slow. Scrolling is especially slow in kate, windows switching is slow, firefox is REALLY slow.

I have direct rendering enabled using the r300 driver, which has been setup automatically by the installer. The computer is a bit old, but it used to be quite fast at the times I could use the proprietary ati-drivers (which dropped support for my card).

How can I test if there is something misconfigured? I used to use xglgears for that, but it outputs the code below:

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.872 FPS

Is there anything I can do, or should I just change the video card? Anything you could recommend?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

In my experience, changing to raster rendering vastly improved KDE4s speed and responsiveness. do this:

sudo apt-get install kde-config-qt-graphicssystem

and then find qt rendering settings in systemsettings. Select raster and logout/back in.

share|improve this answer
    
Thanks for the suggestion, will try that tomorrow (now I am away from that computer) –  Palantir Apr 11 '11 at 6:24
    
also, you want vSync to be disabled in the effects section of systemsettings, and you want the video memory mode (I think that is what it is called) set to shared, not texture from pixmap. –  nerdy_kid Apr 11 '11 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.