Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed Ubuntu 13.04 and it seems my fan is working harder and kind of revs up every thirty second or so.

It came with windows 8 pre-installed and when I ran windows it didn't get nearly as hot.

My laptop is an Acer Aspire V3-571G

share|improve this question

2 Answers 2

I've just spent several hours solving the same issue (I also have V3-571G). Finally, I find following "workaround". At least something.

0.) acer_fancontrol Since kernel is neigher able monitoring nor controlling the FAN, therefore we need some other way. There is "a script" >>>for other Acer models<<< which modify UEFI data directly (on the fly) in order to control the FAN speed.

I consider this method most dangerous since the program may crash anytime. Moreover, it seems that our model (V3-571G) and/or our BIOS version is not supported.

1.) BIOS upgrade I had BIOS version 2.18. Now I upgraded to (hacked) BIOS version 2.21.

1.1) Page: with latest BIOS for V3-571G model (and some others) that is also "hacked". It simply enables hidden "Advanced" options in Acer's BIOS.

So simply download the BIOS from provided link (at site), extract, create bootable USB and upgrade BIOS version on your laptop.

1.2) To make the USB bootable, I used this command

sudo dd if=USBimg32.ima of=/dev/sdc

where /dev/sdc is my USB flash drive.

1.3) Flashing procedure is described here:

Simply put the file in a regular FAT32 formatted USB pen stick.
Turn off notebook, remove battery and power cord from notebook
Attach the USB pen stick on it
Still holding, plug in power cord and wait 3 ~ 5 seconds
Press power button
Release all the buttons
Notebook will turn on with fan and lights only wait about 2~3 minutes and notebook
will power down itself.
Plug in the battery and turn it on.

I followed instruction exactly and it worked.

1.4) Now I've control of FAN speed, based on (just CPU?) temperature. Unfortunately, there are just two values (low and high).

2.) Also don't forget modifying the /etc/default/grub file this way: from this:


to this:

GRUB_CMDLINE_LINUX_DEFAULT="noquiet nosplash acpi_osi=Linux acpi_backlight=vendor"

You can find several referenced what these arguments do, e.g.:

What does the kernel boot parameter "set acpi_osi=Linux" do?

How to control Brightness

share|improve this answer

First of all Ubuntu 13.04 is not supported so I recommend you downloading and installing Ubuntu 15.04 that has the latest drivers and you will see that your temperature is lowered down thanks to new drivers. If not you can always install propietary graphics drivers on your current installation but it is old.

share|improve this answer

protected by Community Jun 28 at 15:05

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.