Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've smartmontools installed on my ubuntu server.

HDD is smart capable:

sudo smartctl -i /dev/sda 



=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Scorpio Blue Serial ATA (Adv. Format)
Device Model:     WDC WD10TPVT-11U4RT1
Serial Number:    WD-WXC1A80P0314
LU WWN Device Id: 5 0014ee 20507d2dc
Firmware Version: 01.01A01
User Capacity:    1,000,204,886,016 bytes [1.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   8
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Tue Sep 10 16:05:58 2013 GET
SMART support is: Available - device has SMART capability.
SMART support is: Disabled

I enable it by running:

sudo smartctl -s on /dev/sda 

If I run command smartctl -i again, I see SMART support is: Enabled. But this goes back to disabled on restart.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Edit your /etc/rc.local file with your favourite text editor, ie: nano /etc/rc.local and add the command to enable smart support before the last line of the script:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

smartctl -s on /dev/sda 

exit 0

Save the changes with Ctrl+O and then Ctrl+X.

That script is runs on every boot so that would enable smart support for that disk on every boot.

share|improve this answer
    
Is this the recommended way of dealing with this issue? –  Sandro Dzneladze Sep 15 '13 at 22:38
    
Not sure, but it should work the way it is. –  Bruno Pereira Sep 16 '13 at 12:16
    
Or you can write your own script and use it on the right levels of init.d. –  Bruno Pereira Sep 16 '13 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.