Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have successfully installed Ubuntu 13.04 as double boot with Windows 8 into my new Asus X74A. Everything works fine, expect the Wifi! although it recognizes the ESSID (see below), it does not switch it ON. Note that under Windows 8 it works fine.

eth0     no wireless extensions.

lo       no wireless extensions.

wlan0    IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:of

Any help!


prgenevo@prgenevo-X75A1:~$ sudo lshw -class NETWORK
*-network DÉSACTIVÉ     
   description: Interface réseau sans fil
   produit: RTL8188CE 802.11b/g/n WiFi Adapter
   fabriquant: Realtek Semiconductor Co., Ltd.
   identifiant matériel: 0
   information bus: pci@0000:02:00.0
   nom logique: wlan0
   version: 01
   numéro de série: 20:68:9d:98:4d:55
   bits: 64 bits
   horloge: 33MHz
   fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192ce driverversion=3.8.0-19-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   ressources: irq:17 portE/S:e000(taille=256) mémoire:f7d00000-f7d03fff
*-network
   description: Ethernet interface
   produit: AR8161 Gigabit Ethernet
   fabriquant: Qualcomm Atheros
   identifiant matériel: 0
   information bus: pci@0000:03:00.0
   nom logique: eth0
   version: 10
   numéro de série: 08:60:6e:95:8d:9a
   taille: 100Mbit/s
   capacité: 1Gbit/s
   bits: 64 bits
   horloge: 33MHz
   fonctionnalités: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=alx driverversion=1.2.3 duplex=full firmware=N/A ip=192.168.0.18 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   ressources: irq:19 mémoire:f7c00000-f7c3ffff portE/S:d000(taille=128)
share|improve this question
2  
Please edit your question to add the result of these terminal commands: rfkill list all and also: lspci -nn | grep 0280 –  chili555 Sep 10 '13 at 11:47

2 Answers 2

You have the correct driver loaded for your device but it is problematic in ubuntu sometimes adding driver parameters help if not compiling the latest driver is usually the only way to get it to work.

Please do:

echo "options rtl8192ce swenc=1 ips=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo modprobe -rfv rtl8192ce
sudo modprobe -v rtl8192ce

Edit:

sudo modprobe -r rtl8192ce 
sudo rfkill unblock all
sudo modprobe rtl8192ce

Edit: If you have windows installed make sure wireless is on in window before you boot ubuntu.

Also go into bios and make sure wireless is enabled if you have that option in the bios if not reset the bios.

Edit:

sudo gedit /etc/rc.local

add the following three lines:

rmmod -f rtl8192ce
rfkill unblock all
modprobe rtl8192ce

Proofread carefully, save and close gedit. Reboot

share|improve this answer
    
did not work details are shown above –  velibra Sep 11 '13 at 17:28
    
@veliba Please don't edit an answer with your "results". You can post your results on paste.ubuntu.com and add a comment with the link here. Please see askubuntu.com/about and askubuntu.com/help (you will be rewarded with a badge if you will do this :) ) –  Radu Rădeanu Sep 11 '13 at 17:36
    
@veliba For example: It did not work; I got the same results: paste.ubuntu.com/6093471. It's not so hard! –  Radu Rădeanu Sep 11 '13 at 17:43
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. –  Wild Man Sep 11 '13 at 20:26
    
Here is the link pastebin.com/a0YZtG02 –  velibra Sep 11 '13 at 21:30

Just try to activate the interface:

sudo ifconfig wlan0 up

and

sudo iwconfig wlan0 txpower on

EDIT: According to the output you should be using a Realtek RTL8188CE.

You can try using that driver (you can find the driver here: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8188CE ) you have to download the "Linux kernel 2.6.24 or later".

So do this:

  1. Download the driver
  2. Uncompress the archive: tar -jxvf linux_mac80211_0012.0207.2013.tar.bz2
  3. Install build-essential and kernel headers (or you won't be able to compile): sudo apt-get install build-essential linux-headers-$(uname -r)
  4. Use the README file inside the archive to compile & install the driver

Anyway the installation process should be:
su -
cd *DRIVER_DIRECTORY* (it should be "rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012.0207.2013"
make
make install
reboot

But as I said, read the README file inside the driver archive to being sure.

share|improve this answer
2  
This answer is confusing to new users. Please provide commands with sudo prefix to avoid confusion. For example say open a terminal by pressing Ctrl+Alt+T and enter each line separately and provide your password when prompted: sudo ifconfig wlan0 up and sudo iwconfig wlan0 txpower on –  user68186 Sep 10 '13 at 16:31
    
Does not work because SIOCSIFFLAGS: impossible because of RF-kill –  velibra Sep 10 '13 at 18:21
    
Do a sudo "sudo rfkill list" and see if you wifi card is soft-blocked (you can see this in the "Soft blocked line"). If yes, this means that your wifi card has been switched off by the kernel; so run a "sudo rfkill unblock wifi && sudo rfkill unblock all" to unlock it. You can now do "sudo rfkill list" again just to check that it's now unlocked. Now the wifi card should work, if not and "iwconfig" keep showing you Tx-Power=off just run the two lines I wrote in the answer, you should now be able to turn the wifi radio on. –  PeppeDAlterio Sep 11 '13 at 6:26
    
Did nid work got:prgenevo@prgenevo-X75A1:~$ sudo rfkill list [sudo] password for prgenevo: 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 1: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no prgenevo@prgenevo-X75A1:~$ sudo ifconfig wlan0 up SIOCSIFFLAGS: Opération impossible du fait de RF-kill prgenevo@prgenevo-X75A1:~$ sudo ifconfig wlan0 up SIOCSIFFLAGS: Opération impossible du fait de RF-kill prgenevo@prgenevo-X75A1:~$ –  velibra Sep 11 '13 at 6:29
1  
@velibra You should not add additional info in the answer section. You should edit your question instead. –  jokerdino Sep 11 '13 at 12:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.