Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 LTS. I accidentally terminated the terminal during a sudo apt-get upgrade or sudo apt-get update. At least that seems to be the most logical explanation of my issue, as my computer started acting strange right after I did that... Thus, I restarted it and now I cannot login to my machine. Instead I get the following message:

init: plymouth-stop pre-start process (1545) terminated with status 1
eth0: no IPv6 routers present
init: failsafe-x main process 1393 terminated with status 1

From Grub, I can access the previous version of Linux. However, I cannot run OpenGL in this previous version of Linux. I hope that could provide some insight.

  1. How do I fix my machine?

If you need any additional information, let me know!

share|improve this question
    
Just try recovery mode. Choose "root shell with network" and resume the operation. –  Danatela Sep 10 '13 at 5:27
    
I found recovery mode but it doesn't help me... –  CodeKingPlusPlus Sep 10 '13 at 16:11
    
@CodeKingPlusPlus - if you do ctrl+alt+f1-6 you should be able to log into a TTY (use your normal username and password). What happens if you run an update & upgrade again? –  fossfreedom Sep 12 '13 at 14:28
    
I have been able to use a terminal and I already tried the update and upgrade... Does anybody know what this error means? I have not really seen anything on google. –  CodeKingPlusPlus Sep 12 '13 at 14:29
    
those errors look like graphics driver issues. What graphics card have you got? Did you previously install any nvidia/amd graphics drivers? If so - where and how did you install these? –  fossfreedom Sep 12 '13 at 14:37

3 Answers 3

Try to hook up your computer with an ethernet cord (larger version of a phone line cord) and attempt to log in again. If you maintain your error, It would appear as if your lan and wlan adapter drivers have been corrupted. You can always repair ubuntu from the live disc or usb you used to install it. Good luck, hope my answers helped.

share|improve this answer
    
How do you fix this with the live disc? –  CodeKingPlusPlus Sep 10 '13 at 16:11

This is what I would have done if I were you.

Short Version

Boot your computer using live disk or USB. Save necessary files to some external media, go for fresh installation.

Detailed Version

  • Boot your computer using a live disk (no longer fits in a CD) or USB stick. Go for the try option, not the installation one. Your computer will run from the external media, not your hard disk.

enter image description here

  • The disks in your computer will be accessible through Nautilus as mounted folders (folders become mounted ones, writing this from memory, so may differ slightly, but I am sure you will be able to find them out). If some partition is not mounted, it will get mounted automatically once you click on the respective icon.

enter image description here

  • Copy all your documents, important files from the disks to some other external media, say a USB disk. Or since LAN is supposed to work, you may want to try file transfer using this option.
  • Now, go for a fresh installation from the inserted media. Since you have saved all your necessary documents, you can now do whatever you want with your machine.

Sounds tedious? Believe me, I had nearly similar experiences in my life. I tried many smaller tasks, without any avail. Eventually I had to go through a sequence like the one above.

share|improve this answer

Maybe that’s a problem with the graphics driver.

What is the output if you change to a tty with Ctrl+Alt+F1, login and type sudo service lightdm restart?

You could try to reinstall the graphics driver.


Opensource driver

Remove proprietary driver

sudo apt-get purge fglrx* xserver-xorg-video-nouveau 

Remove the xorg.conf

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old

Install packages (which system do I have?)

For 32bits systems

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri

For 64bits systems

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

Configure Xorg

sudo dpkg-reconfigure xserver-xorg

Reboot

sudo reboot

If you have an ATI Card you could try to reinstall the driver with

sudo apt-get install fglrx fglrx-amdcccle

Reboot

sudo reboot

If you have an Nvidia Card you could try to reinstall the driver with

sudo sudo apt-get install xserver-xorg-video-nouveau 

Reboot

sudo reboot
share|improve this answer
    
This is a quicky. If you are able to reinstall ubuntu this is the quickest and easiesr method to recover your system. –  Josh Sep 14 '13 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.