Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Gnome 3 just to try it using this command:

sudo apt-get update && sudo apt-get install gnome-shell ubuntu-gnome-desktop
sudo reboot

After this on log screen I have choice between Unity and Gnome desktop enviroment. Gnome works fine but when I have rebooted machine and loged in a Unity session there was a "mixed Unity". It was Unity with Gnome font, Gnome dialogs and a Gnome look terminal window. Also when I boot machine there is a blue GRUB screen instead of ubuntu purple one. I have tried to restore Unity sudo apt-get install unity but nothing was installed ("...there is latest version..."). Lastly I decided to remove Gnome and tried (from here):

sudo apt-get remove libgtk-3-common
sudo apt-get install ppa-purge 
sudo ppa-purge ppa:gnome3-team/gnome3

#This apt-get remove libgtk-3-common was deleted many things...

Now I can't boot Ubuntu anyway, when I choose Ubuntu from grub (this is dual boot) there is just black screen and cursor in uper left corner. I have tried to automatically update grub by choosing appropriate option in recovery mode.

I really don't want to loose this instalation because there are many settings and software that I really need. How to solve this boot problem and how to remove Gnome?

This is report from boot-repair->boot-repair report.

I also tried to install libgtk-3-common but

libgtk-3-common is already the newest version
libgtk-3-common set to manually installed

And tried to sudo apt-get install ubuntu-desktop

I have solved this unmet dependencies by:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.original
sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.original
apt-get autoclean
apt-get autoremove 
sudo apt-get -f install

and then sudo apt-get install --reinstall ubuntu-desktop works and now I can normally boot a Gnome session but Unity still have some problems. There is no launcher, upper line...

share|improve this question
    
see this question –  minerz029 Sep 12 '13 at 9:50
    
Thanks for it I've edited question. –  foki Sep 12 '13 at 10:29
    
It looks like you're missing a window manager and Unity. See this question and this –  minerz029 Sep 12 '13 at 10:31
add comment

1 Answer

If GNOME 3 PPA is giving you troubles, then why not just remove it. As you may know, PPA is nice if you want to test the new technology, but as all tests you may run into problems in the process. If you are suffering problems about GNOME3 PPA, the recommended path of action is to remove them. PPA's were never meant to be solid rock but a way to get the latest of the latest in Ubuntu:

Know what you're installing. Most likely you'll use Launchpad for the majority of your PPA needs, but even so it can be dangerous to your computer. Usually the worry for me is not malicious intent, but conflicting packages. If package A requires a modified version of ffmpeg, and package B in a different repository requires a modified version of ffmpeg too, well, now there's a good chance you might not be able to watch videos, for example, with package A or B or at all.

For a "novice" or "noob" - my best advice is to steer clear of PPA's until you feel confident that you understand a few things about the command line, potential error messages and a few things how to diagnose issues. Foosfreedom

For removing PPA's you will need ppa-purge. If you install GNOME3 from the Ubuntu repositories you get assured of a maximum capability in your system and less likely to run into problems. PPAs are for tester and people that don't need a stable system. If what you need is solid rock where to stand, PPA's are definitively not for you.

Good to read:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.