Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to my uni's public wifi in ubuntu. After an initial attempt that is usually successful, the connection drops after a few minutes (sometimes < 1). After that future attempts to connect may or may not be successful, but after a few initial successes I find myself completely unable to connect.

I had this issue with this laptop before. I ended up buying and installing a new wifi card and (if I remember correctly) installing the proprietary drivers for it, which seemed to fix the issue. However, after reinstalling ubuntu over the summer the problem has re-surfaced, and now I can't seem to find the proprietary drivers I thought I had installed when I last had this issue.

I do not have connectivity issues in windows on this laptop, so I'm pretty sure this is a software/driver issues

This is my wifi card's lspci entry:

03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

and my lsmod: http://paste.ubuntu.com/6041598/

I tried implementing the solution mentioned here: Very slow connection on an Intel(R) WiFi Link 5100 AGN, which did not help my connectivity issues.

share|improve this question

1 Answer 1

enter image description hereAssuming you named the file "/etc/modprobe.d/intel_11n_disable.conf" Then do:

sudo rm /etc/modprobe.d/intel_11n_disable.conf

Then:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

Edit: Please do

gksudo gedit /etc/modprobe.d/iwlwifi.conf

Make this line:

options iwlwifi 11n_disable=1

Look like this:

options iwlwifi 11n_disable=1 swcrypto=1

Proofread carefully, save and close gedit.

Then do:

echo -e '#!/bin/bash\n/sbin/iwconfig wlan0 power off' | sudo tee -a /etc/pm/power.d/wireless

Reboot

Edit:

Go to network manager settings in the top right corner of the screen and set IPV6 to ignore then save and close settings and reboot.

Also it is not a good situation that you have so many networks in range of your wireless and many of them have the same name and all have pretty weak signal strength.

Edit:

You can manually set the mac address of the network you want to connect to and see if that helps. Find the name of the network that you want to connect to by running:

sudo iwlist scan

then click on network manager in the top right corner of the screen>edit connections>click on wireless connection then enter the mac address, click save and reboot.

share|improve this answer
    
This did not seem to fix my connectivity issues. For certain locations the connectivity did seem to improve, but I just tested it in a place where I was totally unable to connect to a network in Ubuntu (and I was able to connect in Windows) –  alecb Sep 10 '13 at 17:41
1  
Sometimes it is the settings of the router that linux drivers have trouble with. When you are at the location that you can not connect too please do: It will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. –  Wild Man Sep 10 '13 at 19:50
    
Using wget when I cannot access the internet might prove problematic. :P Anyway, I currently have internet access on one network -- it seems to be working so the data might not be useful for debugging the problem but this is my wireless-info.txt for my current connection: paste.ubuntu.com/6089767 –  alecb Sep 10 '13 at 20:43
    
I added more commands to run that help in many cases. You have many networks in range and that makes it very hard for network manager to connect to just one, it causes the connection to jump from one to another in many cases. –  Wild Man Sep 11 '13 at 17:13
    
Still having issues (last I tried the connectivity actually seemed worse after those changes, but I can't be sure that I didn't just happen to be somewhere where the connection was poor). Fresh wireless-info.txt: paste.ubuntu.com/6094702 edit: and just to verify I did the new changes correctly: paste.ubuntu.com/6094705 –  alecb Sep 11 '13 at 23:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.