Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my ubuntu 9.04 on standard DELL PC, I have no sound in Flash applets. I had the same problem on 8.10

Sound works fine elsewhere (reading a mp3 with a player for example).

I tried Konqueror, Firefox, Chromium: no sound.

The test consist into reading a YouTube video. It seems to be connected with Flash.

PS: I'm a newbie on linux.

share|improve this question

closed as too localized by Luis Mar 14 '13 at 17:07

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I assume you mean there's no sound in just Flash. I'm just going to edit the post slightly to clarify that. Feel free to rollback if you think it's inaccurate. –  Oli Sep 1 '10 at 15:21

2 Answers 2

I think this is mostly fixed in later versions of Ubuntu but the old fix was something like this:

sudo apt-get install alsa-oss
gksudo gedit /etc/firefox/firefoxrc

In the window that pops up, look for FIREFOX_DSP="none" and replace it with FIREFOX_DSP="aoss". Save and restart Firefox. Note this is clearly only a fix for Firefox.

There are more suggestions on the Flash help page, some more extreme than others.

If upgrading Ubuntu is an option, that might be worth a go too.

share|improve this answer
    
I don't have a /etc/firefox/firefoxrc file actually. Creating one and adding FIREFOX_DSP="aoss" does not make it. Thanks anyway. –  sthiers Sep 8 '10 at 12:27

I have had the same bug in this Version, I think it was related to pulseaudio.

The following might fix it:

  • Deinstalling pulseaudio (will remove package ubuntu-desktop - no worries, it's not really needed)
  • Fresh-Install of Ubuntu 10.4 (upgrading didn't solve the problem if i remember correctly)

I think the problem has to do with one application getting the soundcard exclusively, so no other can access it.

edit: However I had sound in flash, as long as I didn0t start any other application before firefox...

share|improve this answer
    
How did you test sound in flash? (did you use other web browsers?) –  sthiers Sep 8 '10 at 12:29
    
Firefox + Youtube. If you have the same problem as I have, the only solution is a fresh install of a newer Ubuntu version. And no, I did not test other browsers. –  sBlatt Sep 8 '10 at 17:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.