Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to compile different packages from source (e.g., ipsec-tools, openvpn, etc.) I obtain always the same error from the configuration script:

$ ./configure

./configure: This script requires a shell more modern than all
./configure: the shells that I found on your system.
./configure: Please tell ****@***.org and
./configure: ***@***.org about your system, including
./configure: any error possibly output before this message. Then
./configure: install a modern shell, or manually run the script
./configure: under such a shell if you do have one.

On my system I've a bash shell (GNU bash version 3.00).

Looking at those config scripts I've noticed they support bash v.2, so I don't understand where the problem could be.

share|improve this question
    
No, I don't get any permission denied error. Also, the ownerhip settings of /dev/null are correct... –  Marco L. Sep 9 '13 at 10:14
1  
does echo $CONFIG_SHELL show anything? –  Rinzwind Sep 9 '13 at 10:39
    
nope, it doesn't show anything –  Marco L. Sep 9 '13 at 10:46
    
@Rinzwind thanks for the tip. I've solved this problem forcing the autoconf to use bash: CONFIG_SHELL=/bin/bash ./configure –  Marco L. Sep 9 '13 at 12:24

1 Answer 1

Bash 3.00 is quite old (six years or so); I have 4.2 which is already three years old.

Try to use a newer bash; if that fails, try zsh and ksh, both of which can be installed in your Ubuntu with apt-get install ksh and apt-get install zsh, respectively.

share|improve this answer
    
sadly, this is not an option at the moment. I've to stick with bash 3.00 –  Marco L. Sep 9 '13 at 11:56
    
Well, you could try to go to line 236 of the autoconf configure script and remove it (the line is exit 1 at the end of the conditional that gives you the error). You will still see the error message, but the configure script will continue. –  January Sep 9 '13 at 12:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.