Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install MariaDB like this, and got this error:

dpkg: error processing /var/cache/apt/archives/libmysqlclient18_5.5.32+maria-1~raring_amd64.deb (--unpack):
libmysqlclient18:amd64 5.5.32+maria-1~raring (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances
No apport report written because MaxReports is reached already

I tried to install mysql-server instead, but got:

The following packages have unmet dependencies:
libmariadbclient18 : Depends: libmysqlclient18 (= 5.5.32+maria-1~raring) but 5.5.32-0ubuntu0.13.04.1 is to be installed
mysql-server : Depends: mysql-server-5.5 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

apt-get -f install does not work, though:

dpkg: error processing /var/cache/apt/archives/libmysqlclient18_5.5.32+maria-1~raring_amd64.deb (--unpack):
libmysqlclient18:amd64 5.5.32+maria-1~raring (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances

I tried roll back, so sudo dpkg -r mariadb-servermariadb-client-core-5.5 mariadb-client-5.5 mariadb-server-core-5.5 which worked. mariadb-server is not installed apparently. Then I tried sudo dpkg -r libmysqlclient18 but got:

dpkg: dependency problems prevent removal of libmysqlclient18:amd64:
amarok depends on libmysqlclient18 (>= 5.5.13-1).

I don't want to remove amarok as it has been installed for a long time.
How can I solve this error and remove all of MariaDB?

aptitude is not installed, and when I start Ubuntu Software Center it tells me New software can't be installed, because there is a problem with the software currently installed. Do you want to repair this problem now?, when I click Repair an internal error appears:

enter image description here


As requested, output of sudo apt-get check:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libmariadbclient18 : Depends: libmysqlclient18 (= 5.5.32+maria-1~raring) but 5.5.32-0ubuntu0.13.04.1 is installed
E: Unmet dependencies. Try using -f.

Output of apt-cache policy libmysqlclient18 libmariadbclient18:

libmysqlclient18:
  Installed: 5.5.32-0ubuntu0.13.04.1
  Candidate: 5.5.32+maria-1~raring
  Version table:
     5.5.32+maria-1~raring 0
        500 http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu/ raring/main amd64 Packages
 *** 5.5.32-0ubuntu0.13.04.1 0
        500 http://jp.archive.ubuntu.com/ubuntu/ raring-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ raring-security/main amd64 Packages
        100 /var/lib/dpkg/status
     5.5.29-0ubuntu1 0
        500 http://jp.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
libmariadbclient18:
  Installed: 5.5.32+maria-1~raring
  Candidate: 5.5.32+maria-1~raring
  Version table:
 *** 5.5.32+maria-1~raring 0
        500 http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Output of cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list:

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://jp.archive.ubuntu.com/ubuntu/ raring main restricted
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://jp.archive.ubuntu.com/ubuntu/ raring-updates main restricted
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://jp.archive.ubuntu.com/ubuntu/ raring universe
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring universe
deb http://jp.archive.ubuntu.com/ubuntu/ raring-updates universe
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://jp.archive.ubuntu.com/ubuntu/ raring multiverse
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring multiverse
deb http://jp.archive.ubuntu.com/ubuntu/ raring-updates multiverse
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://jp.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse
deb-src http://jp.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu raring-security main restricted
deb-src http://security.ubuntu.com/ubuntu raring-security main restricted
deb http://security.ubuntu.com/ubuntu raring-security universe
deb-src http://security.ubuntu.com/ubuntu raring-security universe
deb http://security.ubuntu.com/ubuntu raring-security multiverse
deb-src http://security.ubuntu.com/ubuntu raring-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu raring partner
# deb-src http://archive.canonical.com/ubuntu raring partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu raring main
deb-src http://extras.ubuntu.com/ubuntu raring main

##############################################################
##################### UNOFFICIAL  REPOS http://repogen.simplylinux.ch ######################
##############################################################

###### 3rd Party Binary Repos

#### Google Chrome Browser - http://www.google.com/linuxrepositories/
## Run this command: wget -q https://dl-ssl.google.com/linux/linux_signing_key.pub -O- | sudo apt-key add -
deb http://dl.google.com/linux/chrome/deb/ stable main

#### Google Earth - http://www.google.com/linuxrepositories/
## Run this command: wget -q https://dl-ssl.google.com/linux/linux_signing_key.pub -O- | sudo apt-key add -
deb http://dl.google.com/linux/earth/deb/ stable main

#### Midori PPA - https://launchpad.net/~midori/+archive/ppa
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A69241F1
deb http://ppa.launchpad.net/midori/ppa/ubuntu raring main

#### Opera - http://www.opera.com/
## Run this command: sudo wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
deb http://deb.opera.com/opera/ stable non-free

#### Oracle Java (JDK) Installer PPA - http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
deb http://ppa.launchpad.net/webupd8team/java/ubuntu raring main

#### VirtualBox - http://www.virtualbox.org
## Run this command: wget -q http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc -O- | sudo apt-key add -
deb http://download.virtualbox.org/virtualbox/debian raring contrib

#### X Updates - https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu raring main


####### 3rd Party Source Repos

#### Gimp PPA (Source) - https://launchpad.net/~otto-kesselgulasch/+archive/gimp
## Run this command: sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 614C4B38
deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu raring main

#### Midori PPA (Source) - https://launchpad.net/~midori/+archive/ppa
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A69241F1
deb-src http://ppa.launchpad.net/midori/ppa/ubuntu raring main

#### Oracle Java (JDK) Installer PPA (Source) - http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
## Run this command: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu raring main

deb http://archive.canonical.com/ raring partner
# deb-src http://archive.canonical.com/ raring partner
deb http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu raring main
# deb-src http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu raring main
deb http://ppa.launchpad.net/atareao/atareao/ubuntu raring main
# deb-src http://ppa.launchpad.net/atareao/atareao/ubuntu raring main
deb http://ppa.launchpad.net/bhdouglass/indicator-remindor/ubuntu raring main
# deb-src http://ppa.launchpad.net/bhdouglass/indicator-remindor/ubuntu raring main
deb http://linux.dropbox.com/ubuntu precise main
# deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu raring main
share|improve this question
    
@Braiam: Added. –  Nicolas Raoul Sep 10 '13 at 2:33
1  
What is the output of apt-cache policy libmysqlclient18 libmariadbclient18 and the output of cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list? –  Braiam Sep 10 '13 at 2:49
    
Ok, now you want to delete MariaDB (the title now suggest that) or repair the package dependencies? –  Braiam Sep 20 '13 at 15:07

4 Answers 4

up vote 5 down vote accepted
+50

Looks like you almost got it. Remove the MariaDB packages:

dpkg -r mariadb-servermariadb-client-core-5.5 mariadb-client-5.5 mariadb-server-core-5.5 libmariadbclient18

Now remove the deb http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu raring main line from your /etc/apt/sources.list

Next make sure the MySql package from the MariaDB aren't still in the cache:

apt-get clean

Finally, reinstall libmysqlclient18:

apt-get install --reinstall libmysqlclient18

share|improve this answer
    
I get: dpkg: warning: ignoring request to remove mariadb-servermariadb-client-core-5.5 which isn't installed dpkg: warning: ignoring request to remove mariadb-client-5.5, only the config files of which are on the system; use --purge to remove them too dpkg: warning: ignoring request to remove mariadb-server-core-5.5 which isn't installed. Anyway I proceeded: removed from sources.list, apt-get clean, but apt-get install --reinstall libmysqlclient18 fails: The following packages have unmet dependencies: libmariadbclient18 : Depends: libmysqlclient18 –  Nicolas Raoul Sep 19 '13 at 3:57
    
you also need to remove libmariadbclient18, with dpkg -r libmariadbclient18. then apt-get clean and apt-get install. if you see more warnings about other maria-specific packages then remove them too. –  cas Sep 20 '13 at 9:46
    
That worked! I also had to do dpkg -r mariadb-client-core-5.5. Well-deserved bounty! –  Nicolas Raoul Sep 24 '13 at 2:02

try with this

sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get update

then try to do what you were trying to do.let me know what you got.

share|improve this answer
    
Output of sudo apt-get check: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libmariadbclient18 : Depends: libmysqlclient18 (= 5.5.32+maria-1~raring) but 5.5.32-0ubuntu0.13.04.1 is installed E: Unmet dependencies. Try using -f. –  Nicolas Raoul Sep 10 '13 at 2:33
    
Output of sudo apt-get autoremove: Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libmariadbclient18 : Depends: libmysqlclient18 (= 5.5.32+maria-1~raring) but 5.5.32-0ubuntu0.13.04.1 is installed E: Unmet dependencies. Try using -f. –  Nicolas Raoul Sep 19 '13 at 1:00

Try removing all the dependency package from synaptic package manager. And use 'aptitude' to install packages instead of apt-get.

Here's why: aptitude-vs-apt-get

I'm guessing it's an issue with the apt-get.

share|improve this answer
    
I can't install aptitude nor synaptic nor anything. Also, Ubuntu Software Center won't start (internal error, added screenshot). –  Nicolas Raoul Sep 17 '13 at 7:23
    
I remember I had the same problem. Have you tried building and installing aptitude from source code? link –  thanmai Sep 17 '13 at 7:26

Ok, I found the issue. Is just not possible. You have packages that depends on the 5.5.32-0ubuntu0.13.04.1 version of libmysqlclient18 while libmariadbclient18 depends on 5.5.32+maria-1~raring.

The solution, either delete the packages that depends of the 5.5.32-0ubuntu0.13.04.1 version with sudo apt-get -f autoremove libmysqlclient18 (NOT RECOMENDABLE) or tell the package maintainer to fix their stuff because is impossible to install it without breaking the system. How I know?

In the long list of 152 packages there are a "critical" packages that depends of that specific version of libmysqlclient18 hence apt-get reuses to delete it and provokes this mayor breakages.

Inform the packages maintainers to fix their stuff correctly.

If you want to know which package is use:

apt-cache rdepends libmysqlclient18=5.5.32-0ubuntu0.13.04.1

Will tell you the packages that has an implicit dependency of that version, then you only need to compare with a list of your installed packages and voila!

share|improve this answer
    
Thanks but it outputs an error: libmysqlclient18:amd64 5.5.32+maria-1~raring (Multi-Arch: no) is not co-installable with libmysqlclient18 which has multiple installed instances –  Nicolas Raoul Sep 19 '13 at 1:01
    
apt-cache rdepends libmysqlclient18 tells me I have 152 packages that depend on it :-/ –  Nicolas Raoul Sep 19 '13 at 2:10
    
Is it normal that libmysqlclient18 depends on libmariadbclient18? –  Nicolas Raoul Sep 19 '13 at 2:12
    
I got the answer... but you won't like it... –  Braiam Sep 19 '13 at 3:02
    
Any solution is better than not being able to install any new software :-) –  Nicolas Raoul Sep 19 '13 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.