Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I boot ubuntu from the live cd without any special options I get the following message:

[ 0.040001] Kernel panic - not syncing: IO-APIC + timer doesn't work! Boot with apic=debug and send a report. Then try booting with the 'noapic' option.
[ 0.040001]

So I booted with the noapic option (and the acpi=off option because the noapic option alone didn't work). It booted fine and I was able to install. Then after the restart I got the above message again. Is there a way to tell ubuntu to use the noapic option when booting from harddrive?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

If you're using GRUB2 (clean-installs of Ubuntu 9.04 and later), edit /etc/default/grub and change the following line: (this may look different on your system, I just took it from mine as an example)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Add noacpi, or whichever kernel option you want, anywhere in the line.

If you're using GRUB Legacy (if you upgraded from a version of Ubuntu before 9.10), please see the GRUB page in the Ubuntu Wiki for details on how to edit your /boot/grub/menu.list to accomplish the same as above.

share|improve this answer
1  
I couldn't execute grub-update from the live cd so I mounted my ubuntu partition and added acpi=off noapic to the kernel line in /boot/grub/grub.cfg that worked, thanks! –  user142 Sep 1 '10 at 16:00
2  
@user142 Make sure you keep those updates in /etc/default/grub - the grub.cfg gets rebuilt every time there is an update to grub (new kernel, etc) –  Marco Ceppi Sep 1 '10 at 16:03
    
just had this issue with an older laptop again and it worked yippee! –  andybleaden Aug 18 '11 at 14:41

To do this you must change the boot parameters through Grub. Open /etc/default/grub as root. Add noapic to the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" or similar. Then run update-grub as root.

share|improve this answer
    
I guess I started writing this as lfaraone posted his answer –  JasonCook599 Sep 1 '10 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.