Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just starting using Ubuntu & completed a clean install of Ubuntu 12.04.3 LTS on a Compaq nc6230 laptop with an Intel PRO/ Wireless 2200BG wireless card. After the installation, I can't connect my nc6230 (Laptop 1) to my home Wifi router (Linksys WAG200G) using WEP encryption.

I encountered the WEP connection problem immediately after the initial OS installation.

Here's a summary of the symptoms I'd encountered:

  1. I can enable the Wifi card by pressing the Wifi Quick Launch Button.
  2. Network Manager can detect & list the AP (same AP I connect to with another laptop).
  3. Network Manager shows it's trying to connect to the AP (blinking icon in system tray).
  4. On the nc6230 (Laptop 1), Network Manager will keep prompting me to key in the WEP password every few minutes.
  5. I'd deleted the old Wifi connection in Network Manager and create a brand-new connection. Network Manager still prompts for the WEP password.
  6. I'd installed the same Ubuntu OS (64-bit) on another laptop (Laptop 2 - Compaq 6510b with Intel PRO/ Wireless 4965 AG or AGN [Kedron]) which can connect to the same router with the same WEP settings. NOTE: I'd encountered the similar problem with my Laptop 2 earlier on. I managed to resolve the problem after performing a clean OS reinstall and upgrade the firmware/ driver of the Intel PRO 4965 AG wireless card).

  7. I've tried resetting Laptop 1's BIOS back to default settings (as suggested in a posting on Ubuntu Forums) but I'm still encountering the same problem.

  8. I could connect to the same AP when I was still running WinXP on Laptop 1.
  9. Since the initial installation, Laptop 1 can connect to the Internet with my Ethernet connection.
  10. All latest system updates've been installed & Laptop 1 successfully rebooted.

How do I resolve this problem? I've searched through the various Ubuntu forums & tried out several suggested solutions (see above) but the problem still persists. Do I need to upgrade Laptop 1's Intel 2200BG's firmware and/or driver? Where can I download the updated version of this firmware/ driver? Could this problem caused by Network Manager?


P.S.: I'd enclosed some info on Laptop 1's network h/w details.

Output for sudo lshw -c network

   description: Ethernet interface
   product: NetXtreme BCM5751M Gigabit Ethernet PCI Express
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:10:00.0
   logical name: eth0
   version: 11
   serial: 00:12:79:be:ff:79
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.128 duplex=full firmware=5751m-v3.29a ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:16 memory:c8000000-c800ffff

       description: Wireless interface
       product: PRO/Wireless 2200BG [Calexico2] Network Connection
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:02:04.0
       logical name: eth1
       version: 05
       serial: 00:15:00:15:a9:e5
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ipw2200 driverversion=1.2.2kmprq firmware=ABG: (Dec 12 2007) latency=64 link=no
maxlatency=24 mingnt=3 multicast=yes wireless=IEEE 802.11bg
       resources: irq:21 memory:c8100000-c8100fff
enter code here

Output for lspci
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
10:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit Ethernet PCI Express (rev 11)

rfkill list all
0: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Output for nm-tools
State: connected (global)
- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ipw2200
  State:             unavailable
  Default:           no
  HW Address:        00:15:00:15:A9:E5


  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            tg3
  State:             connected
  Default:           yes
  HW Address:        00:12:79:BE:FF:79

    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Prefix:          24 (


Output for iwconfig

lo        no wireless extensions.
enter code here
eth0      no wireless extensions.

eth1      IEEE 802.11bg  ESSID:"homebase"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:18:39:39:81:42   
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0s

Output for sudo modprobe ipw2200 

No output
share|improve this question

Try reloading the nic drivers by copying the files into /lib/firmware and reboot your laptop.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.