Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here is what I tried:

$ sudo apt-get install skype
[sudo] password for umpirsky: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install skype-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libasound2:i386 (>= 1.0.23) but it is not going to be installed
                  Depends: libc6:i386 (>= 2.7) but it is not going to be installed
                  Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
                  Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
                  Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
                  Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
                  Depends: libx11-6:i386 but it is not going to be installed
                  Depends: libxext6:i386 but it is not going to be installed
                  Depends: libxss1:i386 but it is not going to be installed
                  Depends: libxv1:i386 but it is not going to be installed
                  Depends: libssl1.0.0:i386 but it is not going to be installed
                  Depends: libgl1-mesa-glx:i386 but it is not going to be installed
                  Recommends: sni-qt:i386 but it is not going to be installed
                  Recommends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I also tried all suggestions from Unable to install Skype on 12.10 64bit, but none of them worked for me.

My sources list:

$ cat /etc/apt/souces.list /etc/apt/sources.list.d/*.list
cat: /etc/apt/souces.list: No such file or directory
deb http://downloads.hipchat.com/linux/apt stable main
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/screencloud/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/splashtop-streamer/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/vkaudiosaver/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb http://ppa.launchpad.net/upubuntu-com/chat/ubuntu quantal main
# deb-src http://ppa.launchpad.net/upubuntu-com/chat/ubuntu raring main

Please help.

UPDATE:

I tried to install teamviewer and got similar error:

enter image description here

UPDATE:

I just installed fresh Ubuntu 13.04 and got same error.

UPDATE:

I installed Skype with:

sudo dpkg --force-depends -i skype-ubuntu-precise_4.2.0.11-1_i386.deb

But can't run it:

$ ll /usr/bin | grep skype
-rwxr-xr-x  1 root root    30701056 мај  7 01:42 skype*
$ /usr/bin/skype
bash: /usr/bin/skype: No such file or directory

UPDATE:

I am able to reproduce this without installing Ubuntu, from live CD.

share|improve this question
1  
I've tidied up this question by removing all comments. In the future, please edit your question with further details. Please DO NOT use comments to add details such as traces. Thanks. –  fossfreedom Sep 30 '13 at 11:12

12 Answers 12

Installing from sources

First, follow all instructions listed in the following post to get rid of unmet dependencies:

Then install Skype as is specified here:

Paraphrasing, this is the correct way to install Skype on Ubuntu 64-bit:

sudo dpkg --add-architecture i386
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype

Installing from .deb file in Ubuntu 12.04+ at 32 or 64-bit

  1. Download Skype for Ubuntu 32-bit Precise i386.
  2. When the download has finished, open the downloaded file as normal from Nautilus.
  3. When prompted, select Open with Ubuntu Software Center (default).
  4. In the right side of the Ubuntu Software Center window that opens, select Install.
  5. Just in case that step 4 doesn't work, try from terminal:

    sudo dpkg --force-depends -i skype-ubuntu-precise_4.2.0.11-1_i386.deb
    

    Note that this step 5 is not ideal, but I'm almost sure that this will work.

Source: Getting started with Skype for Linux.

share|improve this answer
    
I updated my question. Thanks. –  umpirsky Sep 30 '13 at 12:26

Honestly, I think there is a solution that is easier than all the other answers.

If I recall correctly, I installed skype on 13.04 64 bit by going to the downloads page of skype.com, and choosing Ubuntu 12.04. Then you open it with the software center and it takes care of things for you.

I think this is worth the try. If it does not work, leave a comment and I will delete the answer.

share|improve this answer
    
hi, I am using xubuntu 14.04 64bit, and tried what you write in here. but I could not get skype running, it is showing broken package massage, could you help with this problem. –  rashed azad Apr 19 at 5:50
    
@rashedazad feel free to ask a question on this website. Something might have changed with 14.04. –  don.joey Apr 19 at 6:20

As I can understand from the post, answers and the comments (links/gist too), you've made typos and there are multiple sources with duplicate entries.

  1. First, as you made the typo while adding the architecture, correct it using: sudo dpkg --remove-architecture i38
  2. To get rid of duplicate entries, check this answer: How do I remove this duplicate sources.list entry?
  3. Now, open 'Software & Updates', go to 'Other Software' tab and uncheck all that you don't wish to use. Next, run sudo apt-get update
  4. Finally, use the answer given by Radu:

    First, follow all instructions listed in the following post to get rid of unmet dependencies:

    • How do I resolve unmet dependencies? As for the unmet dependencies that don't have a 64-bit version, install the i386 (32-bit) one by searching that package name in 'Ubuntu Software Centre'.

    Then install Skype as is specified here:


    Paraphrasing, this is the correct way to install Skype on Ubuntu 64-bit:

    sudo dpkg --add-architecture i386
    sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
    sudo apt-get update
    sudo apt-get install skype
    

Tip: Copy-paste commands.

share|improve this answer

To install skype there is nothing more easy:

sudo rename -n 's/\.list$/.list.disable/g' /etc/apt/sources.list.d/*.list
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install aptitude
sudo aptitude full-upgrade
sudo aptitude install skype
share|improve this answer

You should use these commands

sudo dpkg --add-architecture i386   # only needed for 64-bit systems
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install ia32-libs
sudo apt-get install skype skype-bin sni-qt:i386

If that works, you can use Skype, else try the command below

sudo apt-get -f install

If none of that works, you could try and get Skype from the official .deb and install from that

wget http://download.skype.com/linux/skype-ubuntu-precise_4.2.0.11-1_i386.deb
sudo dpkg -i skype-ubuntu-precise_4.2.0.11-1_i386.deb

UPDATE:

Try these commands:

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get -f install

Then retry the commands from above starting from sudo apt-get install ia32-libs

share|improve this answer

Please go to http://repogen.simplylinux.ch/ and generate source list. Edit source list.

nano /etc/apt/sources.list

After that update and upgrade your system.

sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade 

Now try to install skype.

share|improve this answer

I went to skype.com and downloaded the ubuntu 12.04 version and then it opened up the software store and asked me to install an add on to make it work on my computer and it is working fine now. I would try that.

share|improve this answer
  1. To get Skype to work in Ubuntu 13.04 Raring Ringtail with proprietary Nvidia / AMD drivers, firstly we'll rename the Skype executable from "skype" to "skype-bin":

    sudo mv /usr/bin/skype /usr/bin/skype-bin
    
  2. Now let's create a file called "skype" under /usr/bin/ - for this we'll launch a text editor as root (I'll use Gedit in the instructions below):

    gksu gksu gedit /usr/bin/skype
    

(I've used "gksu" twice in the command above so Gedit doesn't open a blank tab along with /usr/bin/skype)

And in this file, paste the following:

#!/bin/sh
export LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1
exec skype-bin "$@"

Then save the file.

And finally, run the following command in a terminal:

sudo chmod 0755 /usr/bin/skype

That's it. Now Skype should work in Ubuntu 13.04 Raring Ringtail.

If you want to revert the changes made by using the instructions above, use these commands:

sudo rm /usr/bin/skype
sudo mv /usr/bin/skype-bin /usr/bin/skype

source

share|improve this answer

This method will automatically detect OS architecture and install latest skype:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype && sudo apt-get -f install

Note: If you need to install libqt4-webkit, for that I used Synaptic

Try this:

sudo dpkg --add-architecture i386
sudo apt-get install ia32-libs
sudo apt-get update
wget -O skype.deb http://download.skype.com/linux/skype-ubuntu-precise_4.2.0.11-1_i386.deb
sudo dpkg -i skype.deb
sudo apt-get -f install

Edit 2:

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1

Then Download Skype for Ubuntu 32-bit Precise i386. Select to open with Ubuntu Software Center, once opened, click Install.

Part of the info from Nooslab

share|improve this answer

I am just taking a shot in the dark here but, from your screen shot below:

http://screencloud.net/img/screenshots/8366ca7d55ab0f215f4a614433eadfc1.png

Try going to the "Ubuntu Software Center" and type in the search "libasound2:i386".

I did and got this result:

Shared library for ALSA applications
libasound2:i386

link to screen shot - http://i.imgur.com/2F0q2sW.png

Check to see if they are already installed. If not then try installing this first and then install your Skype...

Hope it works, good luck!

@umpirsky As it says in your screen shot, the libasound2:i386 is dependant on the libc6 file so jut go to Ubuntu Software Center and type in libc6 and try to install that first. If it does not work then check to see if libc6 is dependent on some file and try to install that one then work your way back from there...

It states in the error that: "Further more there could be a conflict between software packages which are not allowed to be installed at the same time". This may be the problem you are having, so you may have to install them separately.

"EDIT"

As "Saurav Kumar" mentioned in the beggining just install "Synaptic" and go through the list adding and installing the list one at a time...

Hope this helps, good luck umpirsky...

share|improve this answer

Looks like some recent Ubuntu update fixed this problem.

I tried to install today and it went well https://gist.github.com/umpirsky/2f465f067d7c7d050fa6.

Thanks everyone who tried to help!

share|improve this answer

Are you using "Main Server" as your dist server?

I had this same problem which i managed to fix by changing my dist server from a local server to "Main Server" in "System Settings" > "Software and Updates".

unfortunately i couldn't find a command line to easily change the dist server, but you could always edit your /etc/apt/sources.list and change the server.

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.