Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I try to connect my laptop on my TV through HDMI connection, it doesn't work (VGA does).

Here is the output for xrandr:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1366x768       60.1*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
   1440x900_60.00   59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
   1920x1080_60.00   60.0  
DP1 disconnected (normal left inverted right x axis y axis)

The resolution found on HDMI1 was get from my .xprofile:

xrandr --newmode "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode VGA1 "1440x900_60.00"
xrandr --addmode HDMI1 "1920x1080_60.00"

I'm using Intel core i5 with HD graphics 3000.

Does anyone know the workaround for this problem?

Thanks!

share|improve this question
    
I have an Intel HD Graphics 3000 and it works just fine. –  FuzzyToothpaste Oct 11 at 23:34

1 Answer 1

I ran into this problem a while ago too, and for me the problem was two-fold:

1/ My on-board Intel graphics doesn't recognize my HDMI port; only the internal laptop screen and the VGA port.

Solution:

Turn on the NVidia card in my BIOS.

Note: "Hybrid" doesn't work: It needs to be "Intel" or "NVidia".

2/ The HDMI cable is a good one, so it needs to be firmly plugged into the port.

Solution:

Push the cable really hard into the slot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.