Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have USB box with drive I removed from my notebook. The drive contains Ubuntu installation. When I connect it to another computer and choose to boot from USB drive I see error: file '/grub/i386-pc/normal.mod' not found followed by grub rescue prompt.

I already tried the boot-repair utility, as well as http://askubuntu.com/a/229453. I also burned rEFInd as suggested in http://askubuntu.com/a/325883/25614 but there is no menu shown and windows start loading. http://askubuntu.com/a/286028/25614 doesn't seem to be working either (also I don't have --root-directory argument in grub-install --help).

Boot repair info: http://paste.ubuntu.com/6079504/

I tried booting on some older computer and it worked.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.