Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have installed Ubuntu 12.04 on Dell Inspiron 1525. After the installation I found out that wireless connection does not work. I was able to connect to the internet via cable. Then I found out that many people have similar problems and read through many posts yet I wasn't able to solve it so here is what I tried.

System->AdditionalDrivers->Broadcom STA wireless driver produced message "Sorry, installation of this driver failed."

Then I installed Synaptic package manager and tried to reinstall and also remove and install bcmwl-kernel-source it always said something like that installation failed (yet synaptic was showing green light next to it)

I regularly rebooted to see if there is any change but haven't seen one.

Then I tried removing bcmwl-kernel-source and adding b43-fwcutter and firmware-b43-lpphy-installer after reboot there was a change. I was able to see options in the menu for connection (up right) like "Enable Wireless" but at the place where I'd expect the list of networks is only (grayed) "Wireless Networks Disconnected" - And they should be there since I was able to connect with other computers, even with Live Ubuntu.

some other info from terminal (in the last state of system described)

katka@katka-Inspiron-1525:~$ lspci | grep 'Network'
0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
katka@katka-Inspiron-1525:~$ sudo iwconfig
wlan2     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

lo        no wireless extensions.

eth2      no wireless extensions.

katka@katka-Inspiron-1525:~$ rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no 

This is as much as I was able to get from other posts and now I don't now what to do next.

share|improve this question

marked as duplicate by Thomas W., Warren Hill, Alaa Ali, Eric Carvalho, guntbert Sep 27 '13 at 17:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Please get a temporary wired ethernet connection. Open a terminal and do:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install firmware-b43-lpphy-installer
sudo modprobe -r wl   <--if it isn't loaded, that's OK, just proceed.
sudo modprobe b43

Detach the ethernet. Your wireless should now be working.

If there are problems, look for and post any clues here:

dmesg | grep -e b43 -e wlan -e 8021
share|improve this answer
    
Thanks, its working, but not satisfyingly enough. It does not detect wifi conections automaticaly, but when I click "connect to hidden wireles network" and type in the name, it will connect. After doing this, it will sometimes display also other available networks and sometimes it won't. After reboot the situation is the same - I have to "connect to hidden wireles network" Is there some way to make it work properly? –  Brano Sep 8 '13 at 21:29
    
Please see my edit. –  chili555 Sep 8 '13 at 23:02
    
I have tried that: "dmesg|grep ..." but the result is really long. Is it supposed to be like that? Here is the link to googledoc file with the result. –  Brano Sep 9 '13 at 12:35
    
I think you have something deeper than wireless going on. Please reboot so we have a clean slate and paste this: dmesg here and give us the link in your reply. paste.ubuntu.com –  chili555 Sep 10 '13 at 11:38
    
It seems that the result of "dmesg" is longer than the window in terminal can admit. Here is the link: paste.ubuntu.com/6087883 but I think, that you wanted full result, so pls tell me how to do it –  Brano Sep 10 '13 at 13:23

protected by Community Sep 27 '13 at 4:40

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.