Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I made an update of my ubuntu 11.04 installation. After rebooting the keyboard and touchpad of my asus eeepc do not work anymore. I can only login with the onscreen keyboard. Seems to be a unity problem. Never had this problem before. How can I make my keyboard work again?

After upgrading I also run the following command: sudo apt-get autoremove

share|improve this question
2  
start your computer with recovery mode (start holdig SHIFT BEFORE the boot, and it will display first the grub menu, select the 2nd entry: "Ubuntu, ... Linux, ... <kernel info> [Recovery mode]") ... then select root shell, and try a system upgrade... will it help? –  B. Roland Apr 9 '11 at 22:36
    
This worked perfectly. It downloaded several packages and after rebooting everything worked as before. During my first installation it said, that several packages were "Kept-back", do you know what that means? Please add a response for your comment, so I can mark this question as solved. –  taco24 Apr 10 '11 at 8:31
1  
Yes, maybe I know, but I have to know what packages... if they was kernel updates, you used: sudo apt-get upgrade, and that doesn't mention kernel things. If you run: sudo apt-get dist-upgrade, it will mention all updates. (I'll post an answer if you like :)) –  B. Roland Apr 10 '11 at 8:44

1 Answer 1

up vote 3 down vote accepted

Maybe you have some problems because of uninstalled packages...

To repair that problem, try:

  1. Start Ubuntu in recovery mode - hold SHIFT key before the system boots, and it will display Grub bootloader. Select the last version of the kernel with the [recovery] in the end of the name. grub menu
  2. Select the root shell option recovery mode
  3. Try to upgrade your system - if there are problems (& errors), post them here... The other way, to select dpkg option - that may fix some other problems.
  4. Reboot - type exit to jump back to recovery menu, then there select resume boot option.
share|improve this answer
1  
selecting the dpkg option worked for me. –  taco24 Apr 10 '11 at 9:41
1  
Had this problem with 12.04. Thank you so much. Worked perfectly. You are a gentleman and a scholar. –  user434885 Jun 23 '13 at 10:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.