Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set up an OpenVPN connection via the network manager on Ubuntu 12.04 following these instructions:

https://www.privateinternetaccess.com/pages/client-support/#ubuntu_openvpn_installer

Initially I could not access any websites when connecting to the VPN network.

I then ticked the box for 'Use this connection only for resources on its network' under IPv4 Settings, Routes.

After ticking the box everything seemed to work. I could connect to the VPN network and open websites.

I only coincidentally noticed though, that although the network manager tells me that I have successfully connected to the VPN network, my IP address does not change.

I then looked into the Private Internet Access configuration files downloaded from the link above and found the port number 1194, which I opened using the firewall configuration tool Firewall.

I also unticked the box 'Use this connection only for resources on its network' and connected to the VPN network. I can do Google searches and access one or two random websites, but then I get a 'connection failed' from the browser.

It seems to connect to the VPN network successfully though. The IP address changes according to the host I am using.

I would be really great full for some tips. I tried to fix this problem for some time but have not been successful in my attempt.

Thanks :-)

share|improve this question
add comment

1 Answer

I was able to solve the problem by adding OpenDNS servers (208.67.222.222, 208.67.220.220) under IPv4 Settings, Automatic (VPN) addresses only. I also reticked the 'Use this connection only for resources on its network' box. Now it's working. IP address is changing.

Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.