Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't install Adobe Flash player. I tried terminal, Ubuntu Software Centre, and Synaptic Package Manager, but I got error message:

Depends: libnss3-1d but it is not going to be installed
Depends: libnspr4-0d but it is not going to be installed

I tried apt-get update, but it's not working. I also tried installing libnss3-1d and libnspr4-0d but I got an error message.

I also tried using Ubuntu-restricted-extras, but I cannot get Flash installed.

share|improve this question
Which Ubuntu release are you running? 64bit or 32bit? – Mitch Sep 8 '13 at 9:11
Can you please run sudo apt-get clean && sudo apt-get update && sudo apt-get install -f && sudo apt-get install flashplugin-installer? – Alaa Ali Sep 8 '13 at 9:31
Mitch : 32-bit. Alaa : that's not working. – setyap Sep 9 '13 at 5:51
Could you run apt-cache policy flashplugin-installer libnss3-1d libnspr4-0d, apt-cache depends flashplugin-installer libnss3-1d libnspr4-0d and sudo apt-get check, edit your question and add the results. – Braiam Sep 9 '13 at 11:43
up vote 1 down vote accepted

Just meant as a hint here - you don't need to install flash-player manually for browsers like firefox. Could be easier to get around that with usage of Chrome Browser. Less stress than many adjustments in firefox - which are getting obsolete again after a few newer versions of firefox ...

share|improve this answer

Following the instructions in Alaa's comment did the trick for me, so thx Alaa!

sudo apt-get clean && sudo apt-get update && sudo apt-get install -f && sudo apt-get install flashplugin-installer
share|improve this answer

Short answer

sudo apt-get install --reinstall libnspr4=2:4.10.2-1ubuntu1
sudo apt-get install flashplugin-installer

Long answer

I tried to do install libnspr4-0d manually, but I got this error:

libnspr4-0d : Depends: libnspr4 (= 2:4.10.2-1ubuntu1) but 2:4.10.7-0ubuntu0.14.04.1 is to be installed

I checked libnspr4 and it was already installed, so I had to downgrade it. So the solution is to check every package and install (or reinstall) it using the version needed by flashplugin-installer

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.