Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was on an old Ubuntu 10.04 GNU/Linux based system which used 2.6.x kernels and I had no problems with the microphone. Now I have done a fresh upgrade to a system based on Ubuntu 12.04 GNU/Linux with kernel 3.2.0-52-generic-pae and my external microphone stopped working. This is my headset's microphone which has its own connector separate from that of the headphone part of the headset. When I connect the microphone's connector to the jack on the front of the laptop (an Acer Aspire 5680 series) and check the Input level on the Input tab of the Sound settings, nothing changes there meaning that no input from the microphone is detected. My internal (laptop) microphone and the microphone in an external (USB) web cam I have work properly, but their quality is very low so I need to use my external microphone which used to work properly. Here are the things I have tried, without success.

  • Added options snd-hda-intel model=auto to /etc/modprobe.d/alsa-base.conf. Also tried model=acer and model=acer-aspire.
  • Chose all possible combinations of Mic, Front Mic, and Line In in Capture (F4) part of alsamixer.
  • Downgraded to older kernels, as far back as 3.2.0-38-generic-pae

There is a similar question here External microphone doesn't work on a Macbook Pro 8,2 even though recording via Internal microphone works fine, which is unanswered at the time I am writing this.

Any ideas what may be causing this and what else I may try?

share|improve this question
    
execute these commands and paste it in your question: sudo uname -a and sudo lsb_release -a –  Saurav Kumar Sep 8 '13 at 18:10
    
uname -a reports the kernel version which is already in my question (and my host name which is irrelevant) and lsb_release -a reports the distribution which is already in my question too. Neither command requires sudo. –  Omid Sep 8 '13 at 19:22
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.