Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to start developing for Ubuntu and Ubuntu phone, but I get an error:

qmlscene: cannot find qt installation of ''

when I attempt to run my application in Ubuntu from the command line. I'm very new to Linux, so if you could fully explain what I need to do to fix it, then that'd be great. I'm running Ubuntu 13.04 in a VirtualBox virtual machine on an Asus N56VZ laptop. I installed the Ubuntu SDK using the instructions on http://developer.ubuntu.com, so I really have no idea what's wrong.

share|improve this question
    
Questions concerning problems with code you've written must describe the specific problem — and include valid code to reproduce it — in the question itself. See SSCCE.org for guidance. Edit your question and include the information asked. –  Braiam Sep 8 '13 at 1:37
1  
But it's not about the code at all. It's about running it. qmlscene is the command to run build and run code. I'm sorry that I didn't make that clearer. Again, the issue is with not being able to build and run my project –  user2437378 Sep 8 '13 at 6:10

2 Answers 2

up vote 1 down vote accepted

I was able to reproduce this by following the Get Started instructions and testing with the Ubuntu Weather App. There must be either an error in the instructions or a bug in the Ubuntu SDK packages.

This seems to work as a temporary workaround:

  1. Look up the name of your Qt installation:

    $ qtchooser -list-versions
    qt5-x86_64-linux-gnu
    
  2. Specify the name using when running qmlscene, which is just a symlink to Qt Chooser:

    $ qmlscene -qt=qt5-x86_64-linux-gnu ubuntu-weather-app.qml
    

    qmlscene: weather

share|improve this answer
    
Works great, thank you very much! –  user2437378 Sep 12 '13 at 21:55

While the above answer is correct in one sense, it's an indication the 'default' configuration has not been installed or is not reachable. qmlscene should work without specifying -qt= option.

The qtchooser listing should show the following on Ubuntu 13.04 for example:

$ qtchooser -list-versions
qt5-x86_64-linux-gnu
default
qt5

The following commands should make sure you are up-to-date:

sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install ubuntu-sdk 

If those do not help to give the above qtchooser listing, additional debugging would be needed. Above all, the 'sudo apt-get dist-upgrade' was previously lacking in the official instructions at http://developer.ubuntu.com/get-started/ which may have caused problems for Ubuntu 13.04 users.

share|improve this answer
    
It was weird actually, I ran the command in the above answer once, and then I never had to specify the QT version again. I guess it just set it as the default or something. –  user2437378 Sep 23 '13 at 15:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.