Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed an ubuntu in a computer with windows, but when i open the computer with ubuntu, there's no desktop environment, only a command line. I've even written my username and password on command line but it's still just a command line. Extra info: when i choose "try ubuntu" with usb booting, there is no desktop neither. I have no internet connection on this computer for instance

edit: I've written the code with lightdm, the screen is full of "starting" and "stopping" different things such as "lightdm display manager" or "save kernel messages". Only "stopping anac(h)ronistic cron" fail others ok. still no desktop

edit2: I added nomodeset and second time modeset=0 in the gnu grub screen. ctrl-x didn't work but i could have boot with f10 (it was written below the screen). Both didn't do any change.

When I tried to set them permanently as in the forum: http://ubuntuforums.org/showthread.php?t=1613132 gksudo gave me an error message.

By the way when I'm opening the computer windows is directly opened if I don't press on esc to enter boot options by f9. I read that it can be because of number of parts more than 4 in hard disk.

share|improve this question
1  
Can you tell us the name of the file you downloaded? –  Braiam Sep 7 '13 at 23:08
    
Also, how did you installed? Using Wubi or you created a partition? –  Braiam Sep 7 '13 at 23:24
    
I downloaded ubuntu-12.04.3-desktop-amd64.iso I created a partition, before starting installation it asked me if I would like to overwrite on windows or make a partition. no problem in usb, because it works in another computer, it might be something about bios configurations of the computer? –  hariseldon Sep 8 '13 at 6:36
    
when i try directly from usb i have a command line as: Welcome to Ubuntu 12.04.3 LTS (GNU/Linux 3.8.0-29-generic x86_64) * Documentation: https:/help.ubuntu.com/ ubuntu@ubuntu:~$ _ –  hariseldon Sep 8 '13 at 7:12
    
When you are in the command line, can you do sudo service lightdm start? If it fails, please, edit your question and write the results. –  Braiam Sep 8 '13 at 7:38

1 Answer 1

I always accomplish setting up desktop by doing this right after installation:

sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get -y install ubuntu-desktop

Viola!

share|improve this answer
    
I changed UEFI to Legacy from by BIOS boot configuration, now it works! thank you very much Braiam –  hariseldon Sep 8 '13 at 10:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.