Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The family computer has 3 users (mom, dad and daughter). All 3 use KDE. Daughter is too young to deal with passwords, so she is a member of the nopasswdlogin group so she can log in without a password. However, when daughter is logged in and dad wants to use the computer, dad goes to "Switch User" and logs in to his account. When daughter wants to play again, she goes to "Switch User" to log back in to her account. She is then faced with a "This session is locked" dialog and prompted for a password.

The same thing happens when daughter is logged in and the computer goes to sleep. Upon waking up, her session is locked and she is prompted for a password.

How can I configure daughter's KDE account so that she is not prompted for a password when either switching back to her account or when the computer wakes up?

share|improve this question

1 Answer 1

If you are using kde 4.9 In the System Settings (systemsettings), in the Hardware section, under Power Management, the Advanced Settings section has a checkbox for "Lock screen on resume" Remove the tick mark and hopefully the problem will be solved.

If you are using kde 4.5.3 Go into System Settings, and in System Administration at the bottom, select Login Screen. From there, go to the Convenience tab and enable passwordless logins for all the users on the system. Do not enable an autologin for any user. Then when you switch users, it should not ask for a password.

Hope this helps...

share|improve this answer
1  
That does indeed work for when the computer goes to sleep and wakes up, thanks. However, when switching user from dad's account to daughter's, she is still faced with a session locked dialog. –  Fred Sep 13 '13 at 2:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.