Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Until yesterday I was having Workstation 9 startup with ubuntu (just added an entry in the Startup Applications GUI). When I start my ubuntu, workstation comes up and every thing runs fine.

Then, I upgraded to Workstation 10. Every thing appears to work with no isues, EXCEPT, it will not startup my virtual machine when it is launched at startup. It shows these errors:

Could not open /dev/vmmon: No such file or directory.
Please make sure that the kernel module `vmmon' is loaded.


Failed to initialize monitor device.


Unable to change virtual machine power state: Internal error

Otherwise, if I just try to play the virtual machine again (by pressing play), it works.

Maybe it is a VMware bug.

Please, any advise?

share|improve this question
Does /dev/vmmon exist? ls -al /dev/vmmon – Mitch Sep 8 '13 at 4:07
yes: me@me-Satellite-L655:~$ ls -al /dev/vmmon crw------- 1 root root 10, 165 Sep 8 01:58 /dev/vmmon – user137017 Sep 8 '13 at 16:01
Post from user Matg: See this question: Unable to start VMWare Workstation after upgrade to 13.04. There's a command sudo vmware-modconfig --console --install-all. Does this help? – Alaa Ali Sep 13 '13 at 9:52
No. I tried that before posting. – user137017 Sep 13 '13 at 14:08
Sounds like the root of the problem is that the vmware monitoring service may have installed/built but isn't starting properly. No ideas on why. The answer below just patchwork fixes by installing it again. I would suspect that doesn't persist through a reboot, or you didn't rebuild the modules after a kernel upgrade. – RobotHumans Nov 5 '14 at 0:24

Run this from the command line:

 sudo vmware-modconfig --console --install-all

Then start the vmplayer.

share|improve this answer
Actually, the problem got fixed by itself. Sorry for not posting. – user137017 Oct 24 '13 at 9:14

The issue will be solved with this command: sudo vmware-modconfig --console --install-all

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.