Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just upgraded from Kubuntu 12.04 to 13.04, reassigning my former home partition to this new version.

Though I live in Nepal, locale settings are set to show English. However, some applications show Nepali numbers or letters.

Skype shows Nepali numbers to display time in chats. Conky (vainly) displays date and time using Nepali numbers and letters. Dolfin shows Nepali number to indicate disk usage.

How can I impose the right locale settings on those applications?

Edit: I found a documentation on locales. locale returns:

LANG=en_GB.UTF-8                                                             
LANGUAGE=en_GB:en                                                            
LC_CTYPE="en_GB.UTF-8"                                                       
LC_NUMERIC=ne_NP                                                             
LC_TIME=ne_NP                                                                
LC_COLLATE="en_GB.UTF-8"                                                     
LC_MONETARY=ne_NP                                                            
LC_MESSAGES="en_GB.UTF-8"                                                    
LC_PAPER=ne_NP                                                               
LC_NAME=ne_NP                                                                
LC_ADDRESS=ne_NP                                                             
LC_TELEPHONE=ne_NP                                                           
LC_MEASUREMENT=ne_NP                                                         
LC_IDENTIFICATION=ne_NP                                                      
LC_ALL= 

So obviously, the NP shouldn't be here. I have to find a way to change the settings through terminal since my System Settings > Locale don't seem to take effect. (Something went wrong with the upgrade?)

share|improve this question

1 Answer 1

For some reason, the System Settings>Locale just didn't take effect.

The locale can be set manually, according to the document linked in the question, by setting the desired locale value instead of the wrong locale value (in my case en_GB.UTF-8 instead of en_NP).

The locale settings are written to /etc/default/locale, hence to modify them: sudo kate /etc/default/locale, change the values, save the file and reboot.

share|improve this answer
    
The question remains: why the GUI settings did not change the file? –  Benjamin Sep 7 '13 at 20:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.