Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a problem in 13.04 and it's a problem with the wifi. Ubuntu will never connect to the network. All of my other devices work fine.

The computer detects the network and pops up the wifi password dialog. I enter the correct password, click ok and it tries to connect for a few seconds and then asks for the password again. I am using a new D-Link Wireless N 150 Pico USB adapter which works fine under windows to connect to the same network.

I searched Google for a few hours and didn't find an answer, maybe someone here could help?

syslog contains:

Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0/wireless): connection 'Wi-Fi connection 1' has security, and secrets exist.  No new secrets needed.
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Config: added 'ssid' value 'kaylag2'
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Config: added 'scan_ssid' value '1'
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Config: added 'psk' value '<omitted>'
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> Config: set interface ap_scan to 1
Sep  7 09:25:40 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: inactive -> scanning
Sep  7 09:25:41 mike-ubuntu wpa_supplicant[1017]: wlan0: SME: Trying to authenticate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.665268] wlan0: authenticate with 00:13:10:e1:f9:a2
Sep  7 09:25:41 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.681287] wlan0: send auth to 00:13:10:e1:f9:a2 (try 1/3)
Sep  7 09:25:41 mike-ubuntu wpa_supplicant[1017]: wlan0: Trying to associate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.686768] wlan0: authenticated
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.687005] rtl8192cu 1-1:1.0 wlan0: disabling HT/VHT due to WEP/TKIP use
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.687010] rtl8192cu 1-1:1.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.687014] rtl8192cu 1-1:1.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.688037] wlan0: associate with 00:13:10:e1:f9:a2 (try 1/3)
Sep  7 09:25:41 mike-ubuntu wpa_supplicant[1017]: wlan0: Associated with 00:13:10:e1:f9:a2
Sep  7 09:25:41 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: authenticating -> associated
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.691496] wlan0: RX AssocResp from 00:13:10:e1:f9:a2 (capab=0x431 status=0 aid=12)
Sep  7 09:25:41 mike-ubuntu kernel: [ 1277.691541] wlan0: associated
Sep  7 09:25:41 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
Sep  7 09:25:51 mike-ubuntu wpa_supplicant[1017]: wlan0: Authentication with 00:13:10:e1:f9:a2 timed out.
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.695734] wlan0: disassociating from 00:13:10:e1:f9:a2 by local choice (reason=3)
Sep  7 09:25:51 mike-ubuntu wpa_supplicant[1017]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Sep  7 09:25:51 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: 4-way handshake -> disconnected
Sep  7 09:25:51 mike-ubuntu NetworkManager[986]: <info> Activation (wlan0/wireless): disconnected during association, asking for new key.
Sep  7 09:25:51 mike-ubuntu NetworkManager[986]: <info> (wlan0): device state change: config -> need-auth (reason 'supplicant-disconnect') [50 60 8]
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.711433] wlan0: deauthenticating from 00:13:10:e1:f9:a2 by local choice (reason=3)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.712868] cfg80211: Calling CRDA to update world regulatory domain
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783416] cfg80211: World regulatory domain updated:
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783432] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783439] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783445] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783450] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783456] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 09:25:51 mike-ubuntu kernel: [ 1287.783461] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 09:25:52 mike-ubuntu NetworkManager[986]: <info> (wlan0): supplicant interface state: disconnected -> inactive
Sep  7 09:26:12 mike-ubuntu kernel: [ 1308.420423] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
Sep  7 09:26:12 mike-ubuntu kernel: [ 1308.422269] sd 6:0:0:0: [sdb] Asking for cache data failed
Sep  7 09:26:12 mike-ubuntu kernel: [ 1308.422282] sd 6:0:0:0: [sdb] Assuming drive cache: write through

I tried to disable WPA on the router and it still doesn't connect, I'm just trying to narrow down the issue.

sudo lshw -C network

*-network
description: Wireless interface physical id: 1 bus info: usb@1:1 logical name: wlan0 serial: 14:d6:4d:a7:0d:2e capabilities: ethernet physical wireless configuration: broadcast=yes driver=rtl8192cu driverversion=3.8.0-19-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

syslog after this: sudo iw wlan0 set power_save off

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) starting connection 'Wi-Fi connection 1'

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0/wireless): access point 'Wi-Fi connection 1' has security, but secrets are required.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0/wireless): connection 'Wi-Fi connection 1' has security, and secrets exist.  No new secrets needed.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Config: added 'ssid' value 'kaylag2'

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Config: added 'scan_ssid' value '1'

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Config: added 'key_mgmt' value 'WPA-PSK'

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Config: added 'psk' value '<omitted>'

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> Config: set interface ap_scan to 1

Sep  7 11:59:52 mike-ubuntu NetworkManager[969]: <info> (wlan0): supplicant interface state: inactive -> scanning

Sep  7 11:59:53 mike-ubuntu wpa_supplicant[1193]: wlan0: SME: Trying to authenticate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)

Sep  7 11:59:53 mike-ubuntu kernel: [ 1331.829097] wlan0: authenticate with 00:13:10:e1:f9:a2

Sep  7 11:59:53 mike-ubuntu NetworkManager[969]: <info> (wlan0): supplicant interface state: scanning -> authenticating

Sep  7 11:59:53 mike-ubuntu kernel: [ 1331.844435] wlan0: send auth to 00:13:10:e1:f9:a2 (try 1/3)

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.048053] wlan0: send auth to 00:13:10:e1:f9:a2 (try 2/3)

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.051835] wlan0: authenticated

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.052717] rtl8192cu 1-1:1.0 wlan0: disabling HT/VHT due to WEP/TKIP use

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.052779] rtl8192cu 1-1:1.0 wlan0: disabling HT as WMM/QoS is not supported by the AP

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.052786] rtl8192cu 1-1:1.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP

Sep  7 11:59:53 mike-ubuntu wpa_supplicant[1193]: wlan0: Trying to associate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.056098] wlan0: associate with 00:13:10:e1:f9:a2 (try 1/3)

Sep  7 11:59:53 mike-ubuntu NetworkManager[969]: <info> (wlan0): supplicant interface state: authenticating -> associating

Sep  7 11:59:53 mike-ubuntu wpa_supplicant[1193]: wlan0: Associated with 00:13:10:e1:f9:a2

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.089970] wlan0: RX AssocResp from 00:13:10:e1:f9:a2 (capab=0x431 status=0 aid=12)

Sep  7 11:59:53 mike-ubuntu kernel: [ 1332.090161] wlan0: associated

Sep  7 11:59:53 mike-ubuntu NetworkManager[969]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake

Sep  7 12:00:03 mike-ubuntu wpa_supplicant[1193]: wlan0: Authentication with 00:13:10:e1:f9:a2 timed out.

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.094561] wlan0: disassociating from 00:13:10:e1:f9:a2 by local choice (reason=3)

Sep  7 12:00:03 mike-ubuntu wpa_supplicant[1193]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3

Sep  7 12:00:03 mike-ubuntu NetworkManager[969]: <info> (wlan0): supplicant interface state: 4-way handshake -> disconnected

Sep  7 12:00:03 mike-ubuntu NetworkManager[969]: <info> Activation (wlan0/wireless): disconnected during association, asking for new key.

Sep  7 12:00:03 mike-ubuntu NetworkManager[969]: <info> (wlan0): device state change: config -> need-auth (reason 'supplicant-disconnect') [50 60 8]

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.106375] wlan0: deauthenticating from 00:13:10:e1:f9:a2 by local choice (reason=3)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.112407] cfg80211: Calling CRDA to update world regulatory domain

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164006] cfg80211: World regulatory domain updated:

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164102] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164109] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164116] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164121] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164127] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

Sep  7 12:00:03 mike-ubuntu kernel: [ 1342.164132] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

ok, to try to narrow down the issue I thought it might be that the signal might be too weak so I moved the access point closer, I also disabled the security and tried to connect again and still no luck. I'm not sure if there is anything that stands out in here:

Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) starting connection 'kaylag2'
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0/wireless): connection 'kaylag2' requires no security.  No secrets needed.
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Config: added 'ssid' value 'kaylag2'
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Config: added 'scan_ssid' value '1'
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Config: added 'key_mgmt' value 'NONE'
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> Config: set interface ap_scan to 1
Sep  7 12:27:36 mike-ubuntu NetworkManager[868]: <info> (wlan0): supplicant interface state: inactive -> scanning
Sep  7 12:27:37 mike-ubuntu wpa_supplicant[906]: wlan0: SME: Trying to authenticate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)
Sep  7 12:27:37 mike-ubuntu kernel: [  115.581772] wlan0: authenticate with 00:13:10:e1:f9:a2
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Sep  7 12:27:37 mike-ubuntu kernel: [  115.620391] wlan0: send auth to 00:13:10:e1:f9:a2 (try 1/3)
Sep  7 12:27:37 mike-ubuntu wpa_supplicant[906]: wlan0: Trying to associate with 00:13:10:e1:f9:a2 (SSID='kaylag2' freq=2437 MHz)
Sep  7 12:27:37 mike-ubuntu kernel: [  115.630642] wlan0: authenticated
Sep  7 12:27:37 mike-ubuntu kernel: [  115.631154] rtl8192cu 1-1:1.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
Sep  7 12:27:37 mike-ubuntu kernel: [  115.631164] rtl8192cu 1-1:1.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
Sep  7 12:27:37 mike-ubuntu kernel: [  115.632450] wlan0: associate with 00:13:10:e1:f9:a2 (try 1/3)
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> (wlan0): supplicant interface state: authenticating -> associating
Sep  7 12:27:37 mike-ubuntu wpa_supplicant[906]: wlan0: Associated with 00:13:10:e1:f9:a2
Sep  7 12:27:37 mike-ubuntu wpa_supplicant[906]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:13:10:e1:f9:a2 completed (auth) [id=0 id_str=]
Sep  7 12:27:37 mike-ubuntu kernel: [  115.642953] wlan0: RX AssocResp from 00:13:10:e1:f9:a2 (capab=0x421 status=0 aid=4)
Sep  7 12:27:37 mike-ubuntu kernel: [  115.643075] wlan0: associated
Sep  7 12:27:37 mike-ubuntu kernel: [  115.643160] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> (wlan0): supplicant interface state: associating -> completed
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'kaylag2'.
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> (wlan0): device state change: config -> ip-config (reason 'none') [50 70 0]
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> dhclient started with pid 2201
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Beginning IP6 addrconf.
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Sep  7 12:27:37 mike-ubuntu dhclient: Internet Systems Consortium DHCP Client 4.2.4
Sep  7 12:27:37 mike-ubuntu dhclient: Copyright 2004-2012 Internet Systems Consortium.
Sep  7 12:27:37 mike-ubuntu dhclient: All rights reserved.
Sep  7 12:27:37 mike-ubuntu dhclient: For info, please visit https://www.isc.org/software/dhcp/
Sep  7 12:27:37 mike-ubuntu dhclient: 
Sep  7 12:27:37 mike-ubuntu dhclient: Listening on LPF/wlan0/14:d6:4d:a7:0d:2e
Sep  7 12:27:37 mike-ubuntu NetworkManager[868]: <info> (wlan0): DHCPv4 state changed nbi -> preinit
Sep  7 12:27:37 mike-ubuntu dhclient: Sending on   LPF/wlan0/14:d6:4d:a7:0d:2e
Sep  7 12:27:37 mike-ubuntu dhclient: Sending on   Socket/fallback
Sep  7 12:27:37 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3 (xid=0x2a921615)
Sep  7 12:27:39 mike-ubuntu avahi-daemon[864]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::16d6:4dff:fea7:d2e.
Sep  7 12:27:39 mike-ubuntu avahi-daemon[864]: New relevant interface wlan0.IPv6 for mDNS.
Sep  7 12:27:39 mike-ubuntu avahi-daemon[864]: Registering new address record for fe80::16d6:4dff:fea7:d2e on wlan0.*.
Sep  7 12:27:40 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4 (xid=0x2a921615)
Sep  7 12:27:44 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x2a921615)
Sep  7 12:27:54 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x2a921615)
Sep  7 12:27:57 mike-ubuntu NetworkManager[868]: <info> (wlan0): IP6 addrconf timed out or failed.
Sep  7 12:27:57 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Sep  7 12:27:57 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Sep  7 12:27:57 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Sep  7 12:28:04 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x2a921615)
Sep  7 12:28:14 mike-ubuntu dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15 (xid=0x2a921615)
Sep  7 12:28:20 mike-ubuntu kernel: [  158.449728] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
Sep  7 12:28:20 mike-ubuntu kernel: [  158.451338] sd 6:0:0:0: [sdb] Asking for cache data failed
Sep  7 12:28:20 mike-ubuntu kernel: [  158.451348] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <warn> (wlan0): DHCPv4 request timed out.
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 2201
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) started...
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> (wlan0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <warn> Activation (wlan0) failed for connection 'kaylag2'
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> (wlan0): deactivating device (reason 'none') [0]
Sep  7 12:28:22 mike-ubuntu avahi-daemon[864]: Withdrawing address record for fe80::16d6:4dff:fea7:d2e on wlan0.
Sep  7 12:28:22 mike-ubuntu avahi-daemon[864]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::16d6:4dff:fea7:d2e.
Sep  7 12:28:22 mike-ubuntu avahi-daemon[864]: Interface wlan0.IPv6 no longer relevant for mDNS.
Sep  7 12:28:22 mike-ubuntu kernel: [  161.024993] wlan0: deauthenticating from 00:13:10:e1:f9:a2 by local choice (reason=3)
Sep  7 12:28:22 mike-ubuntu wpa_supplicant[906]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Sep  7 12:28:22 mike-ubuntu kernel: [  161.040777] cfg80211: Calling CRDA to update world regulatory domain
Sep  7 12:28:22 mike-ubuntu NetworkManager[868]: <info> (wlan0): supplicant interface state: completed -> disconnected
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132211] cfg80211: World regulatory domain updated:
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132227] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132231] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132234] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132237] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132239] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 12:28:22 mike-ubuntu kernel: [  161.132242] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sep  7 12:28:23 mike-ubuntu avahi-daemon[864]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::16d6:4dff:fea7:d2e.
Sep  7 12:28:23 mike-ubuntu avahi-daemon[864]: New relevant interface wlan0.IPv6 for mDNS.
Sep  7 12:28:23 mike-ubuntu avahi-daemon[864]: Registering new address record for fe80::16d6:4dff:fea7:d2e on wlan0.*.
share|improve this question
    
What's the output of sudo lshw -C network? (Please add that to your question by editing, thanks!) –  Eliah Kagan Sep 7 '13 at 17:46
    
maybe same problem here? askubuntu.com/questions/363196/… –  pragmatic_programmer Oct 22 '13 at 1:54
    
In my Inspiron N4010, sudo tail -f /var/log/syslog displays: too long to be included in a comment –  PHP Learner Apr 10 at 9:52
    
I have similar problem in my Ubuntu 13.10 with two different DELL Laptops, one is Inspiron N4010 and other is Latitude D630. I am note sure that the problem is the same in both laptops, but the problem is about WiFi connecting to networks in both of them.<br/> My laptops has had no problem with wireless networks before upgrading to 13.10. Is there a final solution to all WiFi problems of Ubuntu 13.10? –  PHP Learner Apr 10 at 12:35

2 Answers 2

You can try to turn off the wireless power saving that tends to disconnect the card too soon:

sudo iw wlan0 set power_save off

Edit: Some more suggestions...

From the output you sent it could be that the ipv6 is failing to connect

Edit connections > chose your network then click edit > IPV6 tab > set method to "ignore"

I've seen other threads with people having trouble with certificates: Authentication in wireless network

  sudo nano /etc/NetworkManager/system-connections/YOUR-NETWORK-NAME

and comment out the line (put a # in front of) system-ca-cert=true

Could it be a firmware problem for your usb adaptor? You could try to connect via ethernet cable and do an update via software updater.

Last thing that comes to mind, just delete the current connection and start over...

Let us know how it went

share|improve this answer
    
This did not work, do you have any other suggestions? I added the output to the above question –  user190911 Sep 7 '13 at 21:01
2  
Disabling IPv6 on the network fixed the problem for me, great! Quite mysterious why this would fail like this however... –  anarcat Mar 10 at 1:37

As I can see dhclient can't retrieve IP from router. At least IPv6. So try to set IPv6 to "ignore" and/or enable/disable using of IPv6/IPv4. All this didn't help me (I have same log). I set IPv4 manually. As first I set random IP and just connect to router. Here I have no Internet but I'm connected to router. Then I nmap'ed network to find router IP: nmap 192.168.0.0/23 And then set router IP as gateway.

This is not a solution for all situations but it helped me tonight to connect to hotel free wi-fi. Also I had to set DNS. I used google public dns but you can set any other.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.