Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 13.04 and kde 4.11.1 My problem is that firefox scrolling is slow and laggy.

I'll give you some more information:

  • Firefox 23.0
  • my video card is an ATI HD6870 and I have the FGLRX drivers 13.4 installed
  • it's not related to flash because it happens even on web pages where there is not flash
  • it's not related to ads because I use plugins to block ads
  • it also happens with unity so it's not a desktop environment related problem
  • it's not about the number of addons I have installed because I have done a fresh firefox installation and it happens the same and I have the same number of addons on firefox on windows and it works better on windows
  • I have tried both these addons for smooth scrolling https://addons.mozilla.org/it/firefox/addon/yet-another-smooth-scrolling/ and https://addons.mozilla.org/it/firefox/addon/smoothwheel/ and the scrolling is worse with them
  • I have activated "no tearing desktop" in catalyst control center because I need it when playing mkv movies and "catalyst A.I"
  • I have also installed chromium and it's much smoother and faster and I have no scrolling problems with it so
  • I also have a notebook with ubuntu 13.04, kde and same firefox version with same addons, it has a nvidia video card and scrolling is much smoother and faster in firefox rather than on my computer with the ati video card

Any advice to solve it? Thanks

share|improve this question

3 Answers 3

ATI's proprietary drivers are notorious for their bad 2D performance. Unfortunately there is not much you can do about this for now. However, Ubuntu 13.10 will ship with Linux >3.11 which comes with significant performance and power management improvements to the open source radeon drivers, which have always been better at 2D rendering.

I woul advise you to try upgrading to 13.10 when it's released in October. Until then, I fear, you will have to deal with the performance issues surrounding FGLRX.

share|improve this answer
    
ok thanks, I wish I could find a solution for that. –  Frank Sep 9 '13 at 15:51
    
Still quite slow (sometimes), in 13.10 and 3.11.0-14-generic x86_64, with default opensource drivers. –  kolen Dec 2 '13 at 14:44
    
@kolen what graphics card are you using, if I may ask? More recent AMD chips (HD7xxx+) are run with radeonSI, which is still quite far away from standard radeon performance. –  Glutanimate Dec 2 '13 at 17:22
    
@Glutanimate sorry, I don't know exactly, lspci says "[AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]", this is on Lenovo Thinkpad L412. I'm not even sure if it is really ATI, not Intel (specs for L412 don't list ATI). –  kolen Dec 3 '13 at 7:07
    
Also, Chromium doesn't have problems with scrolling on this machine. And most of time scroll in Firefox is also quite smooth, but sometimes starts to become slow. –  kolen Dec 3 '13 at 7:09

Try setting these options I also have the fglrx drivers. I'm using an older version but firfox scrolling was much slower than chromes.

I changed some options on firefox's preferences. In the general tab, un-check the "Use hardware acceleration when available" and check "Use autoscrolling" and "Use smooth scrolling".

It's a simple change but removing the hardware acceleration seemed to have improved my scrolling and button performance a bit more where I no longer feel like tearing my hair out. Good luck.

share|improve this answer

These settings worked for me with Elementary OS Luna, 'X.Org X Server 1.11.3' (From 'X -version' in terminal) and legacy 13.1 drivers from ppa:makson96/fglrx on a ATI Mobility Radeon 4570 graphics card.

In Firefox, type "about:config" in address bar and set:

  • gfx.xrender.enabled = false
  • layers.acceleration.force-enabled = true

In Firefox preferences -> General tab, check:

  • use autoscrolling
  • use smooth scrolling
  • use hardware acceleration when available

Now type "sudo aticonfig --initial" (if you haven't generated a xorg.conf file already) and then "sudo amdcccle" to launch Catalyst Control Center and do the following:

  • Disable tear free desktop in display options
  • Set "wait for vertical refresh" to "always on" in 3d->more settings

(Optional)

My other settings in Catalyst Control Center are as follows. (I am not a heavy gamer and though I don't think they'll help you with the laggy firefox scrolling, I am still listing them below):

  • "Override application settings" unchecked in 3D-> Anti-aliasing, Adaptive anti-aliasing and anisotropic filtering.
  • 3D -> MipMap detail set to high quality
  • Catalyst A.I. -> Enabled -> Set to advanced
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.