Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

VMWARE-VIX command "vmrun" failing

I have checked in the online resources of the product documentation, and in discussion groups where other people experience the same issue.

I have the following configuration

  • Ubuntu 13.04 (x64)
  • VMware Player 6.0
  • VMware-VIX API 1.12.2

... and when I try to run the command in the format:

  • vmrun -T player start /path/vm.vmx

I get an error:

*Unable to connect to host. Error: The specified version was not found.*

Forum proposed solution:

  • others with the same issue claimed the solution was to edit a file
  • /usr/lib/vmware/configurator/vixwrapper-product-config.txt
  • to add / modify the line (to ensure it has your correct version of VM player)
  • player 16 vmdb 6.0.0 Workstation-10.0.0-and-vSphere-5.5.0

... but when I open the player, it seems that I do already have v6.0.0 (according to the "help > about" menu item in the player GUI.

... so if it is not the wrong version in that config file ... what is causing the problem?

UPDATE

  • when I try to run the command instead as just:

$ vmrun start /path/vm.vmx (without the -T and "player" host type specification)

... I get the error:

  • Service type VIX_SERVICEPROVIDER_VMWARE_WORKSTATION was specified, but not installed

So is this indication that it thinks I have installed workstation instead of player?

How can I change that?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

SOLUTION

  • ok, just solved this one as well
  • in case anyone else encounters this issue, here is the solution:

vmrun command is ignoring its own config file:

  • /usr/lib/vmare/vixwrapper-product-config.txt

I am not sure why, but even when you use the command as follows:

  • vmrun -T player start /path/vm.vmx

... it is checking & finding vmware workstation NOT player (even if the config file has the correct version of player listed), and then complaining that workstation is not installed.

So, here is how I got around it:

  1. Uninstall vmware player: vmware-installer -u vmware-player
  2. Uninstall vmware-vix: vmware-installer -u vmware-vix
  3. Install vmware workstation: same process as player (remember to chmod +x the bundle)

Surprisingly, what you will find is that you now have both player AND workstation installed, even though if you try installing workstation while player is already installed, the installer will tell you that it cannot do it.

It has also reinstalled VIX as part of workstation, and VIX has this time correctly picked up vmplayer ... so you may now start it at the command line with vmrun

note

  • I was unable still to vmrun via ssh login from another computer
  • Like myself, you may want to start this vm automatically when ubuntu boots (which it should do fine, and that is my next step also)
share|improve this answer
    
I suspect (just a guess) that the developer at VMware who tested the product before putting it out there, may have done so on a non-clean install, and so didn't notice this issue him/her-self, because the config files left behind by a previous vmware workstation install were still there, and so what happened was the bug got overlooked, as it did not occur for them ... but that's just a guess, it could be a million other things too. –  Mr.President Sep 8 '13 at 5:21

I ran into this as well. Installing Workstation 10.0 does work and I noticed something. Workstation comes with Player 6.0 and VIX 1.13. I wonder why they haven't released 1.13 separately.

share|improve this answer
    
did the solution I discovered work in your situation too? –  Mr.President Oct 5 '13 at 11:31
    
Yes it did. Also I'd like to mention that VIX 1.13 was released so I suspect that we can bypass installing Workstation and just used Player 6.0 with VIX 1.13. –  user198515 Oct 14 '13 at 21:29
    
nice thanks for that ... it was a particularly annoying problem :-) –  Mr.President Oct 15 '13 at 23:54

Check the dash before the 'T' option in the vmrun command. I had copied it from this web page and it was using a long dash character instead of a regular dash:

http://www.steelrat.info/en/ubuntu/zapusk-vmware-player-na-ubuntu-bez-graficheskogo-interfeysa/

This caused the error where it complained it could not find workstation:

Error: Service type VIX_SERVICEPROVIDER_VMWARE_WORKSTATION was specified, but not installed

I got this same error when I used a lower case 't' instead of 'T', so I think this error message is from vmrun not getting the 'player' option. Changing to a regular dash (and a capital 'T') fixed the problem, so now I can launch my VM in the player from the command line:

VM="/opt/vmware/Ubuntu_Node/Ubuntu 64-bit.vmx
vmrun -T player start "$VM" nogui
vmrun -T player suspend "$VM"

If you want to use vmware player to run a service, you may want to check this out: http://serverfault.com/questions/70887/vmware-player-running-as-a-service (the answer by David Gladfelter worked for me)

share|improve this answer
    
Can you please edit your post and copy/paste the full command you referred to, and also post the link as reference. That would be very helpful to some of those, dealing with the same problem in finding a solution. –  v2r Feb 23 at 1:43
    
yeah the command was all correctly applied ... it wasn't the -T –  Mr.President Feb 27 at 1:52
    
I have just started at Uni ... but if I get the chance I will go back through my notes & find more detail to add to this post ... just not sure right now where it is & have a lot else on my plate –  Mr.President Feb 27 at 1:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.