Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 12.04 (Precise) with kernel 3.8 now. Virtualbox fails with this error:

Kernel driver not installed (rc=-1908)
The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

One proposed solution I saw was:

sudo apt-get remove virtualbox-dkms
sudo apt-get install virtualbox-dkms

That fails with this message:

sudo apt-get install virtualbox-dkms
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  virtualbox-dkms
0 upgraded, 1 newly installed, 0 to remove and 34 not upgraded.
Need to get 676 kB of archives.
After this operation, 3,899 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise-updates/universe virtualbox-dkms all 4.1.12-dfsg-2ubuntu0.3 [676 kB]
Fetched 676 kB in 2s (258 kB/s)          
Selecting previously unselected package virtualbox-dkms.
(Reading database ... 458635 files and directories currently installed.)
Unpacking virtualbox-dkms (from .../virtualbox-dkms_4.1.12-dfsg-2ubuntu0.3_all.deb) ...
Setting up virtualbox-dkms (4.1.12-dfsg-2ubuntu0.3) ...
Loading new virtualbox-4.1.12 DKMS files...
First Installation: checking all kernels...
Building only for 3.8.0-29-generic
Building initial module for 3.8.0-29-generic
Error! Bad return status for module build on kernel: 3.8.0-29-generic (x86_64)
Consult /var/lib/dkms/virtualbox/4.1.12/build/make.log for more information.
 * Stopping VirtualBox kernel modules                                                 [ OK ] 
 * Starting VirtualBox kernel modules                                                         * No suitable module for running kernel found
                                                                                      [fail]
invoke-rc.d: initscript virtualbox, action "restart" failed.
share|improve this question
1  
Try this sudo apt-get install --reinstall linux-headers-$(uname -r) && sudo apt-get install linux-source . After the installation completes, run sudo /etc/init.d/vboxdrv setup –  NikTh Sep 6 '13 at 23:17
    
@NikTh - that does not work. /etc/init.d/vboxdrv does not exist or is not compatible with the kernel version. –  MountainX Sep 7 '13 at 0:17

3 Answers 3

up vote 5 down vote accepted

After applying my solution from http://askubuntu.com/a/342372/36661, the problem came back again after additional system updates (video driver). I chatted with VirtualBox devs on IRC and they told me that Ubuntu does not regularly accept bug fixes from the VirtualBox devs. They recommended that I install the latest VirtualBox package from virtualbox.org, which I did. That solved the problem.

The download link for Linux is:

https://www.virtualbox.org/wiki/Linux_Downloads

It is actually a simpler install because you don't need to install guest additions separately.

share|improve this answer

The solution is found in this comment on the bug report:

https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1076603/comments/13

Workaround (precise linux-image 3.8.*)

wget -O /tmp/virtualbox.patch 'http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=99;filename=vbox-wheezy.patch;att=1;bug=696011'
cd /usr/src/virtualbox-4.1.12/
patch -p4 < /tmp/virtualbox.patch
dkms autoinstall

If you don't want to reboot, you may have to run this command:

sudo modprobe vboxdrv
share|improve this answer

I had to go throught a lot before it worked for me, but the last piece was MountainX answer here :

sudo apt-get remove --purge virtualbox
sudo apt-get autoremove
sudo apt-get install --reinstall linux-headers-$(uname -r)
sudo apt-get install virtualbox
sudo dkms install virtualbox/4.1.12

sudo wget -O /tmp/virtualbox.patch 'http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=99;filename=vbox-wheezy.patch;att=1;bug=696011'
cd /usr/src/virtualbox-4.1.12/
sudo patch -p4 < /tmp/virtualbox.patch
sudo dkms autoinstall
sudo modprobe vboxdrv

I still had to reboot because of an error with eth0 that had to do with the vboxdrv. But now it's good.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.