Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to have an ntfs partition mounted at startup, so I used this solution to mount it automatically. (Using a program to set the automatic mounting: "Storage Device Manager" - pysdm.)

At a certain point I wanted this for an external drive (fat32) that is most of the time connected to the computer, which was not usually mounted when the computer started.

All went well until I noticed that in Thunar it was not possible to create new folder (or file) - the option was greyed out - on the external drive (while on the ntfs partition all was well):

enter image description here

I have also noticed that the use of the "Storage Device Manager" in the way presented by the linked answer had changed the mount point of the drives involved: before, external drive's point had been /media/cipricus/SAMSUNG/, now it is /media/sdb1/; the ntfs drive had the mount point /media/cipricus/3060-0887/ and now it is /media/sda5/. (But, as specified, there is no problem with the ntfs partition.)

Uninstalling the program and trying to go back to the older situation didn't work, the partition and the external drive continued to mount at the new mount points.


UPDATE: I was able to revert to the old mount points by using the same program, but this did not solve the issue with the external drive. Even worse, I had to un-check the options for mounting at boot for both drives involved for the boot was stopped with an error message that mounting them was not possible.


What I want is to find a way to go back to the situation from before installing the program and making those settings in the first place.


(A second external drive, for which I didn't used "Storage Device Manager" to make it mount at startup, keeps mounting the usual way, /media/cipricus/USB-HDD/, and I can create folders on that one.)

share|improve this question
    
yes because you don't have any access to the new location where the drive is mounted. In short you have to use chown and chmod commands to get the privileges to work on that location. –  Saur.K Sep 6 '13 at 18:38
    
If you open a terminal and do touch /media/sdb1/test_user what do you get? What do you get if you do sudo touch /media/sdb1/test_root? What is the output of mount|grep ' /media/sdb1 '|cut -d'(' -f2? –  Joseph R. Sep 9 '13 at 14:03
    
@cipricus Ok!! First it is very important to know where is your disk mounted and what mount access permission it is using? So please provide the result of this command: mount –  Saur.K Sep 9 '13 at 21:24
    
@SauravKumar - the mountpoint for the external HDD (unlike the internal) is the old one now but still cannot create folders. mount gives this –  cipricus Sep 9 '13 at 21:37
    
@cipricus: pretty strange! so your new mount point for sdb1 is /media/sdb1 as you described in your post.. right? –  Saur.K Sep 9 '13 at 21:41
show 2 more comments

2 Answers

up vote 1 down vote accepted
+50

First of all, try to not use anymore PySDM sience this application is deprecated starting with Ubuntu 12.10 and higher. Futhermore, starting with Ubuntu 12.10, the default mount points was moved to /media/$USER and from here your problems which collide head with PySDM.

So, instead to use anymore PySDM, I suggest you to use AriOS Automount (.deb) (see here how to install a ".deb" file):

AriOS Automount is a small utility [...] and its main advantage over PySDM is that it doesn't require any kind of configuration: just install it and you're done, all your partitions (it should work with any kind of partition: EXT4/3/2, NTFS, FAT and so on) will be automatically mounted the next time you log in.

AriOS Automount works without touching /etc/fstab and it can be enabled / disabled either from the Startup Applications or via the menu, by launching "Auto-mount Settings".

Source: How To Mount Partitions Automatically On Startup In Linux ~ Ubuntu / Linux blog.

In Xfce "Auto-mount Settings" appears under Menu/System

enter image description here

And can be enabled/disabled easily

enter image description here


If I have not convinced you and you sill want to use PySDM, try to change the mount point to /media/$user/devicename (/media/cipricus/SAMSUNG, respectively /media/cipricus/3060-0887/):

PySDM

And:

PySDM

share|improve this answer
    
indeed the second option you mention (cipricus as owner user) allows creating files and folders –  cipricus Sep 9 '13 at 23:13
    
after making that setting, but also unchecking 'The file system is mounted at boot time', and then uninstalling pysdm, the initial situation is in place: which is what my question finally asks. maybe i will test the Arios staff in the future. –  cipricus Sep 10 '13 at 9:04
    
AriOS Automount works as intended and without the problems that I encountered when trying to make a similar setting with other apps. i have edited to add images –  cipricus Sep 10 '13 at 10:14
add comment

Changing the ownership and permission may help you to access your drive.

These steps would help you to do so.

  • First un-mount your /dev/sdb1 drive

    sudo umount /dev/sdb1
    
  • And then change the ownership of /media/sdb1 to working user.

    sudo chown -R cipricus:cipricus /media/sdb1
    

    if cipricus is your Ubuntu user's name (if this command fails says: directory not found then ignore previous step i,e un-mounting)

  • Then change the access permission

    sudo chmod -R 774 /media/sdb1
    
  • And last mount the driver again.

    sudo mount -a
    

    if it doesn't mount then try to mount from icon from your home folder or from gparted.

Reply what happens..

share|improve this answer
    
I ask those who press thumb down to give reasons! What wrong you found in this! This is fully verified by me and working great!! If you need further assistance just reply and tell me the problem you got! This is quite a suggestion that would be modified according to the scenarios.. –  Saur.K Sep 9 '13 at 22:23
    
as i had already changed the mountpoint with that program, i have tested your commands replacing /media/sdb1 with /media/cipricus/SAMSUNG/ but that did not work (could not create folders). so, i changed the mount point of the hdd with Storage Device Manager to /media/sdb1 but still no luck after firing those commands. maybe i should restart. in Storage Device Manager i had un-checked 'The filesystem is mounted at boot time' because had experienced problems at boot –  cipricus Sep 9 '13 at 22:50
    
no luck. tested the commands with both mount points (/media/sdb1 and /media/cipricus/SAMSUNG/ - as i can edit those with Storage Device Manager). but still those options are greyed out in both cases –  cipricus Sep 9 '13 at 22:58
    
@SauravKumar What's the point to use sudo ch... blablabla /media/sdb1 since there is nothing after sudo umount /dev/sdb1? Because of this I suspect your downvote... I abstain from voting since you said This is fully verified by me and working great!! (although I'm sure is not so) –  Radu Rădeanu Sep 9 '13 at 23:34
    
@RaduRădeanu: that is why I mentioned to repeat the steps without un-mounting /media/sdb1. since System Device Manager is auto-mounting the drive /media/sdb1 removes automatically when it un-mounts. You belief it or not! After this suggestion I was going to suggest the same thing or traditional file mounting way to Cipricus. Any way thanks for your good and clear post.. :) –  Saur.K Sep 10 '13 at 6:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.