Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running off a live CD as my Ubuntu 12.04 build cant load the desktop. Reading around I thought it was an issue with my nvidia drivers so I have reinstalled them. lightdm looks like its loading correctly no problem, when I turn it on it takes me directly to tty1 rather than the desktop - like it usually does.

My log file (/var/log/Xorg.0.log) is:

[   345.667] 
X.Org X Server 1.12.3
Release Date: 2012-07-09
[   345.672] X Protocol Version 11, Revision 0
[   345.674] Build Operating System: Linux 2.6.24-29-xen x86_64 Ubuntu
[   345.676] Current Operating System: Linux ubuntuWalker 3.5.0-39-generic #60~precise1-Ubuntu SMP Wed Aug 14 15:38:41 UTC 2013 x86_64
[   345.676] Kernel command line: BOOT_IMAGE=/vmlinuz-3.5.0-39-generic root=/dev/mapper/ubuntuWalker-root ro nomodest
[   345.679] Build Date: 09 July 2012  05:20:18PM
[   345.680] xorg-server 2:1.12.3+git20120709+server-1.12-branch.60e0d205-0ubuntu0ricotz~precise (For technical support please see http://www.ubuntu.com/support) 
[   345.681] Current version of pixman: 0.24.4
[   345.682]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   345.682] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   345.685] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep  6 10:55:34 2013
[   345.685] (==) Using config file: "/etc/X11/xorg.conf"
[   345.686] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   345.686] (==) ServerLayout "Layout0"
[   345.686] (**) |-->Screen "Screen0" (0)
[   345.686] (**) |   |-->Monitor "Monitor0"
[   345.686] (**) |   |-->Device "Device0"
[   345.686] (**) |-->Input Device "Keyboard0"
[   345.686] (**) |-->Input Device "Mouse0"
[   345.686] (==) Automatically adding devices
[   345.686] (==) Automatically enabling devices
[   345.686] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   345.686]    Entry deleted from font path.
[   345.686] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[   345.686] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[   345.686] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   345.686] (WW) Disabling Keyboard0
[   345.686] (WW) Disabling Mouse0
[   345.686] (II) Loader magic: 0x7f7c56a57b00
[   345.686] (II) Module ABI versions:
[   345.686]    X.Org ANSI C Emulation: 0.4
[   345.686]    X.Org Video Driver: 12.0
[   345.686]    X.Org XInput driver : 16.0
[   345.686]    X.Org Server Extension : 6.0
[   345.687] (--) PCI:*(0:0:2:0) 8086:0166:1028:0534 rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[   345.687] (--) PCI: (0:1:0:0) 10de:0dfc:1028:1534 rev 161, Mem @ 0xf5000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   345.687] (II) Open ACPI successful (/var/run/acpid.socket)
[   345.687] (II) LoadModule: "extmod"
[   345.687] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   345.687] (II) Module extmod: vendor="X.Org Foundation"
[   345.687]    compiled for 1.12.3, module version = 1.0.0
[   345.687]    Module class: X.Org Server Extension
[   345.687]    ABI class: X.Org Server Extension, version 6.0
[   345.687] (II) Loading extension MIT-SCREEN-SAVER
[   345.687] (II) Loading extension XFree86-VidModeExtension
[   345.687] (II) Loading extension XFree86-DGA
[   345.687] (II) Loading extension DPMS
[   345.687] (II) Loading extension XVideo
[   345.687] (II) Loading extension XVideo-MotionCompensation
[   345.687] (II) Loading extension X-Resource
[   345.687] (II) LoadModule: "dbe"
[   345.688] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   345.688] (II) Module dbe: vendor="X.Org Foundation"
[   345.688]    compiled for 1.12.3, module version = 1.0.0
[   345.688]    Module class: X.Org Server Extension
[   345.688]    ABI class: X.Org Server Extension, version 6.0
[   345.688] (II) Loading extension DOUBLE-BUFFER
[   345.688] (II) LoadModule: "glx"
[   345.688] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[   345.693] (II) Module glx: vendor="NVIDIA Corporation"
[   345.693]    compiled for 4.0.2, module version = 1.0.0
[   345.693]    Module class: X.Org Server Extension
[   345.693] (II) NVIDIA GLX Module  304.88  Wed Mar 27 14:46:57 PDT 2013
[   345.693] (II) Loading extension GLX
[   345.693] (II) LoadModule: "record"
[   345.693] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   345.693] (II) Module record: vendor="X.Org Foundation"
[   345.693]    compiled for 1.12.3, module version = 1.13.0
[   345.693]    Module class: X.Org Server Extension
[   345.693]    ABI class: X.Org Server Extension, version 6.0
[   345.693] (II) Loading extension RECORD
[   345.693] (II) LoadModule: "dri"
[   345.693] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   345.693] (II) Module dri: vendor="X.Org Foundation"
[   345.693]    compiled for 1.12.3, module version = 1.0.0
[   345.693]    ABI class: X.Org Server Extension, version 6.0
[   345.693] (II) Loading extension XFree86-DRI
[   345.693] (II) LoadModule: "dri2"
[   345.693] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   345.693] (II) Module dri2: vendor="X.Org Foundation"
[   345.693]    compiled for 1.12.3, module version = 1.2.0
[   345.693]    ABI class: X.Org Server Extension, version 6.0
[   345.693] (II) Loading extension DRI2
[   345.693] (II) LoadModule: "nvidia"
[   345.693] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[   345.694] (II) Module nvidia: vendor="NVIDIA Corporation"
[   345.694]    compiled for 4.0.2, module version = 1.0.0
[   345.694]    Module class: X.Org Video Driver
[   345.694] (II) NVIDIA dlloader X Driver  304.88  Wed Mar 27 14:28:14 PDT 2013
[   345.694] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   345.694] (--) using VT number 8

[   345.696] (EE) No devices detected.
[   345.696] (==) Matched intel as autoconfigured driver 0
[   345.696] (==) Matched vesa as autoconfigured driver 1
[   345.696] (==) Matched fbdev as autoconfigured driver 2
[   345.696] (==) Assigned the driver to the xf86ConfigLayout
[   345.696] (II) LoadModule: "intel"
[   345.697] (WW) Warning, couldn't open module intel
[   345.697] (II) UnloadModule: "intel"
[   345.697] (II) Unloading intel
[   345.697] (EE) Failed to load module "intel" (module does not exist, 0)
[   345.697] (II) LoadModule: "vesa"
[   345.697] (WW) Warning, couldn't open module vI have reconfigured esa
[   345.697] (II) UnloadModule: "vesa"
[   345.697] (II) Unloading vesa
[   345.697] (EE) Failed to load module "vesa" (module does not exist, 0)
[   345.697] (II) LoadModule: "fbdev"
[   345.698] (WW) Warning, couldn't open module fbdev
[   345.698] (II) UnloadModule: "fbdev"
[   345.698] (II) Unloading fbdev
[   345.698] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   345.698] (II) NVIDIA dlloader X Driver  304.88  Wed Mar 27 14:28:14 PDT 2013
[   345.698] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   345.698] (++) using VT number 8

[   345.698] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[   345.698] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[   345.698] (EE) No devices detected.
[   345.698] 
Fatal server error:
[   345.698] no screens found
[   345.698] 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   345.698] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   345.698] 

Any tips would be very kind. I am at a loss, google seems to have people who have had similar issues, but they have solved them by deleting X11.conf and regenerating it. That didnt seem to work for me...

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.