Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have created a shell script for a custom action which is working fine. I want to run this .sh file (mon.sh) on pressing Alt+F15.

I have done the following: In gconf-editor, under apps>metacity>keybinding_commands, edited command_1 with value

"/home/administrator/My Scripts/mon.sh" (tried without quotes also)

under apps>metacity>global_keybindings, edited run_command_1 with value

<Alt>F15

But the script is not getting executed when pressing Alt+F15

What is that I am missing?

share|improve this question
    
If you are using gnome-shell, your windowmanager is not metacity, it ist mutter –  david Apr 9 '11 at 9:42
    
I am using standard ubuntu installation. So what could it be? I am not sure about what is gnome-shell. I am running gnome, that's all I know. –  iJeeves Apr 9 '11 at 9:44
add comment

1 Answer

up vote 2 down vote accepted

I have no idea if you are using the right gconf-keys, but you can configure this via gui:

If you are using Ubuntu without desktopeffects metacity is your windowmanager, then you should use System ▸ Preferences ▸ Keyboard Shortcuts to add your command and set the keybinding.

If desktopeffects are activated, you are using compiz windowmanager. Install compizconfig-settings-manager Install compizconfig-settings-manager, run it and enter your script in the Commands preferences.

share|improve this answer
    
That worked. I didn't know it was this straightforward. –  iJeeves Apr 9 '11 at 10:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.