Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I recently changed the default font using dconf tool. That was ok, and after trying that font, I opened dconf again and clicked "Restore Default" button. Then the screen was unresponsive, I forced it to shutdown. Next when I tried to login, the login screen was ok, but after logging in, nothing would show up, not even launcher, terminal, folders on Desktop etc.,. Only visible things are alert box to ask me to confirm shutting down when I press power button. What might be the reason for this and what are possible solutions?

I tried the solution mentioned for the original question, but I get the error

GtkWarning: Default font does not have a family set
GtkWarning: Default font does not have a positive size set

Is there any way to correct this without logging in as a new user?

Tried Solutions:

Unity doesn't load, no Launcher, no Dash appears

Unity doesn't load, no Launcher, no Dash appears (for this, I get an error saying

ERROR unity.launcher.trashlaunchericon TrashLauncherIcon.cpp:62 Could not create file   monitor for trash uri:Operation not supported

Segmentation fault(core dumped)

Unity doesn't load, no Launcher, no Dash appears

Unity doesn't load, no Launcher, no Dash appears

Unity doesn't load, no Launcher, no Dash appears

Unity doesn't load, no Launcher, no Dash appears

Everything gone except desktop

(all the above links are different).

All the above solutions didn't work and one more thing that started happening is when I do

export DISPLAY=:0 ccsm

and enter UI by Ctrl+Alt+F7, it says, CompizConfig-Settings-Manager has stopped working unexpectedly.

I tried re-installing ccsm but, it says, it is already installed and it is the newest version.

OS: Ubuntu 12.04

share|improve this question

marked as duplicate by Web-E, Eliah Kagan, guntbert, Mitch, Alaa Ali Sep 6 '13 at 9:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Press ctrl+alt+t add a new user "adduser newname" then login with that user –  dedunumax Sep 6 '13 at 6:28
    
Did you reboot? –  Braiam Sep 6 '13 at 15:27
    
yes, I tried sudo reboot. Nothing changed. I tried sudo adduser also, but even then my files are gone. That is not a solution atleast for me. –  hatter Sep 6 '13 at 16:15
    
yeah, tried it. It didn't work –  hatter Sep 6 '13 at 17:55
    
Can you put all the relevant information, including links to the solutions you tried (and if possible, even brief summaries of them) into your question? Right now it's unclear what you've done and whether or not this should still be considered a duplicate. Also, what about all the other solutions in that question? If you can try them too, I recommend that (and add information about them as well by editing your question). If you beleive they don't apply, please edit your question to explain why. –  Eliah Kagan Sep 6 '13 at 18:31

2 Answers 2

up vote 0 down vote accepted

Best Solution

Remove .config,.local, .cache and .fontconfig from your home directory will make your system as it was a new

Follow these simple steps

  • Open terminal(CTRL+ALT+T, if terminal does not then press CTRL+ALT+F1 to go to CLI tty1 mode) first make a directory as a backup

    cd ~
    
    mkdir backup
    
  • Then copy above mentioned directories to backup

    cp -R .config .local .cache .fontconfig backup/
    
  • Then remove all mentioned directories:

    rm -r .config .local .cache .fontconfig
    
  • Then restart your system

    sudo reboot
    
  • That's it.. Your system will be rebooted in new default configuration.


Try these if above mentioned steps didn't help

Method 1

You just need to turn the Unity plugin back on:

  1. Press Ctrl+Alt+F1 and log in.
  2. Install compizconfig-settings-manager:

    sudo apt-get install compizconfig-settings-manager
    
  3. Then run it by doing this:

    export DISPLAY=:0
    ccsm
    

    The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

  4. Press Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes) to get back to the graphical display where there should be a CompizConfig Settings Manager screen sitting there.

  5. Find the Unity plugin. Enable it.

  6. Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to TTY1 and running sudo reboot.

Method 2

For 12.10 and below:

Press Ctrl+Alt+T for a terminal and run ccsm, then re-enable your 'Unity' plugin.

You also may then need to run a unity --reset.

In 13.04:

unity --replace is deprecated. Instead, use the following:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reboot if it doesn't work right away.

Source: Unity doesn't load, no Launcher, no Dash appears

share|improve this answer
    
I suppose he can't open terminal and has to open first virtual console. –  sorgel Sep 6 '13 at 6:52
    
then he should give a try to ctrl+alt+f1 :) –  Saurav Kumar Sep 6 '13 at 6:54
    
I tried this, using tty1 but it was of no use. –  hatter Sep 6 '13 at 17:46
    
what happened? What errors you got? –  Saurav Kumar Sep 6 '13 at 17:49
    
Since this post is marked as duplicate, you would get a better solution at this and this links.. Give it a try. Hope it works for you. –  Saurav Kumar Sep 6 '13 at 17:56

I have no idea about reasons, but it looks like profile settings were corrupted.

  1. Press Ctrl+Alt+F1 and log in.

  2. Type:

    mv ~/.config/dconf/user ~/.config/dconf/user.backup

  3. Reboot.

New profile settings will be generated. Your old setting are saved in ~/.config/dconf/user.backup

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.