Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Y570 laptop with Optimus drivers (dual Intel embedded, NVIDIA GT 555M cards). Playing a game, i noticed I forgot to utilize OPTIRUN to make sure I was using my nVidia card.

When I tried to run the command, I got an error message saying the system didn't know where my nVidia card was (and longer) I know I'd had my laptop configured to use bbswitch/bumblebee in the past so i was a bit perplexed.

At some point, after rebooting, i noticed Unity no longer worked... running ccsm, I noticed OpenGL was not, and could not be enabled... all windows show up without boarders.

I've tried wiping and reinstalling everything i can think of, but i can't get unity running, so i've brought my question here. Of any of the hacks i've done, its all been apt related, if any boot hacks where tried (there was a Lenovo specific hack that involved editing /etc/modules i tried, and some DKMS packages) i went back and removed/disabled them if they didn't work, so as not to compound my problem.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.