Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

What is the answer to "are you root" in Ubuntu 12.10. I was installing the restricted extras for the 12.10 when I got this message after typing my password. I typed yes and now all I see are y in the command prompt. please help me, I am new.just installed it yesterday.

share|improve this question

marked as duplicate by Eliah Kagan, Radu Rădeanu Aug 20 at 12:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

"Are you root?" from apt-get is not expecting you to type an answer - by doing so you have accidentally executed the command yes, which does just what it says

DESCRIPTION
       Repeatedly output a line with all specified STRING(s), or `y'.

You can stop it just by typing Ctrl-C in the terminal.

The "Are you root?" question is just meant to give you a hint why the command you just tried failed i.e. because you didn't have sufficient privileges to run it, and should have used sudo

sudo apt-get install ubuntu-restricted-extras
share|improve this answer

As steeldriver says, this is not a question that you answer interactively. Instead, it is a reminder that you must run commands like apt-get and aptitude as root, for package installation to succeed.

If you're not running it as root or are not sure if you are--in particular, if you are not using sudo--then you should run it as root with sudo. See this question for more information:

If you are using sudo but still get that error, that's strange. There are some similar errors can occur when permission to access a lock file is denied due to another concurrently running package management utility or stale locks (that continue existing after the utility they represent is no longer running). So some of the answers here may help:

If none of this helps, then you'll have to provide more information. In particular, to get better answers, you should add the complete and exact text from the Terminal, including the lines showing commands you are running (and especially the command or commands that result in the "are you root" message), to your question, by editing your question.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.