Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was impatient with a torrent download and then I opened Transmission's Preferences and went changing everything I could to as close as possible to infinite, closed and OK.

After seeing that the speed was still the same I went over the Preferences dialog again and set the values of “Queue” section under “Downloading” tab to “999999999999”, although it doesn't allow such values and reset to the maximum permitted. Obviously that changing that wouldn't increase the speed, although I was veeery impatient, and after changing “Downloads sharing data in the last N minutes are active”, which also didn't accepted the astronomic number and reset my entry to “28410”, Transmission froze, I tried to force it to close and open it again but it lags to start and when it do start, already starts frozen.

Now not even removing or purging or manually deleting it's files and then installing again transmission-gtk and transmission-common will do the job.

I suspect that some configuration file is being kept after purging transmission, because when I install it again, all my torrents are still there (and I only use magnet links) and they show the correct progress bars. After starting Transmission it will work for 3 seconds and freeze after that, in these 3 seconds I managed to open Preferences dialog and I saw that the value of “Downloads sharing data in the last N minutes are active” is still “28410”.

If at least I knew where the file that stores these values is, I could manually reset them all. And when I start a Guest session and open Transmission it will work normally, reinforcing that the problem is in the value of “Downloads sharing data in the last N minutes are active” that I changed up to the maximum.

What should I do?

share|improve this question
    
You can't speed a torrent up. It's made to give you more bandwidth the more you seed files.. –  Seth Sep 5 '13 at 23:03
    
Yeah I know, although I can change the maximum of peer per torrent, but as I was veeery impatient I went on changing everything, of course that wouldn't help, but would make me happier haha –  Rodrigo Martins Sep 5 '13 at 23:07
    
@Seth Where did you get that information from? –  Richard Sep 5 '13 at 23:07
    
@searchfgold6789 I don't remember.. It was a long time ago when I was looking up what exactly bittorrent was. I'll see if I can find it again though. –  Seth Sep 5 '13 at 23:08
    
Well, it doesn't work exactly how you said Seth, although there are some private trackers that do it, but I only use public trackers, that doesn't limit your speed based on your seed rate. Although Transmission have some customizable options, such as maximum peers per torrent, maximum number of active torrents, upload/download bandwidth limit, and what I was doing was setting those limits as higher the possible. –  Rodrigo Martins Sep 5 '13 at 23:58

1 Answer 1

up vote 3 down vote accepted

You can try to edit the following file "settings.json".

NOTE: Make sure that transmission is not running. you can kill it with: pkill transmission

1) Open a terminal and type:

  • gedit ~/.config/transmission/settings.json

2) Searh for the lines 19 and 47 ("download-queue-size" & "queue-stalled-minutes") and edit them.

enter image description here

By default the "download-queue-size" key is set to 5 and the "queue-stalled-minutes" is set to 30.

Hope it helps.

share|improve this answer
    
That is it! Just worked, thanks. –  Rodrigo Martins Sep 6 '13 at 12:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.